About this Document

[image]

Signal Processing Component Library for .NET Documentation
About this Document
Send Feedback

This help file describes how to use the Signal Processing Component Library for .NET to perform single-channel and dual-channel FFT operations and to calculate signal metrics on time-domain data.

Intended Audience

This document is intended for engineers, scientists, technicians, OEMs, system integrators, or others responsible for developing application programs using .NET Framework 2.0 and later and Microsoft® Visual Studio .NET 2005 and later.

It is assumed that you are a proficient programmer in Visual C# or Visual Basic .NET, and that you have familiarity with signal processing principles and the requirements of your application.

What You Should Learn from this Document

This document describes the components of the Signal Processing Component Library for .NET, and describes how to develop a program using these components. Using this document, you should be able to develop an application using the properties and methods of these components.

Send comments on this topic to info@datx.com

Copyright © 2013 by Data Translation, Inc.


Getting Started

[image]

Signal Processing Component Library for .NET Documentation
Getting Started
Send Feedback
  • What is the Signal Processing Component Library for NET
  • What You Need
  • Creating Your Own Program
  • Using the Example Programs
  • Distributing Your Program


What is the Signal Processing Component Library for NET

[image]

Signal Processing Component Library for .NET Documentation
What is the Signal Processing Component Library for NET
Send Feedback

The Signal Processing Component Library for .NET contains a comprehensive set of .NET components for developing signal processing applications in Visual C# and Visual Basic .NET. Using the properties and methods of these components, you can perform single and two-channel FFT operations, and calculate signal metrics for time-domain data.

The open design architecture of the Signal Processing Component Library for .NET allows hardware-independent support. This component library requires a single developer license; the dll can be distributed royalty-free.


What You Need

[image]

Signal Processing Component Library for .NET Documentation
What You Need
Send Feedback

You can download the Signal Processing Component Library from the Data Translation web site (http://www.datatranslation.com/products/test-and-measurement-software/Signal-Processing-Library/default.asp ). You then have 14 consecutive calendar days in which to use the features of the component library. After the trial period has elapsed, you must purchase a single developer license to continue to use the component library.

To use the Signal Processing Component Library for .NET, ensure that you have installed the following software on your system:

  • Windows XP (32-bit), Windows Vista (32-bit or 64-bit), Windows 7 (32-bit or 64-bit), or Windows 8 (32-bit or 64-bit)

  • Visual Studio 2005 to 2012

  • .NET Framework 2.0 to 4.5

Note

You can deploy applications on the following operating systems: Windows XP Professional, Windows XP Home Edition, Windows Vista, Windows 7, Windows 8, and Windows Server 2003.


Creating Your Own Program

[image]

Signal Processing Component Library for .NET Documentation
Creating Your Own Program
Send Feedback

To create your own application program using the Signal Processing Component Library for .NET, do the following:

  1. Start Microsoft Visual Studio .NET.

  2. Click File, click New, and then click Project.

  3. Select the language you want to develop in (Visual Basic Projects or Visual C# Projects), and the template that you want to use (such as, Windows Forms Application).

  4. Enter the project name and where you want to save your project, and then click OK. The design environment is shown.

  5. View the Toolbox in Visual Studio .NET. (In Visual Studio, click the View menu, and then select Toolbox.)

  6. From the Data Translation tab, drag the SingleChannelFFT, DualChannelFFT, and/or SignalMetrics components on to your form. The licensing dialog appears:

  7. To use the trial version of the library, click Continue Evaluation. When the 14-day trial period has elapsed, you must purchase a license key from Data Translation to continue using the library.

  8. To purchase a license key, click Purchase. Once you have purchased the license key, click Enter License to enter the license number for unlimited use of the library; once a valid license is entered, this dialog will no longer appear.

  9. Open and save any forms that use the SingleChannelFFT, DualChannelFFT, or SignalMetrics components to ensure that the license takes effect.

  10. With the SingleChannelFFT, DualChannelFFT, or SignalMetrics component selected on your form, use the Properties window to configure the settings for each property of the component using the information in this document to aid you. Alternatively, you can configure the properties in code. An example of the Properties window for the SingleChannelFFT component follows:

  11. Call the methods for each component in code using the example programs and the information in this document to aid you.

  12. To build your program, click Build from the main menu, and then click Build Solution.

  13. To run your program, click Debug from the main menu, and then click Start.

  14. To save your program, click File, and then click Save All.

  15. When you are finished, click File, and the click Close Solution before exiting from Microsoft Visual Studio .NET.

Note

When you drag a component from the Signal Processing Component Library for .NET on to your form, the appropriate references are made in your project to the assembly (DataTranslation.SignalProcessing.dll).

To see all the properties and methods of each component, click Object Browser from the main window, double-click DataTranslation.SignalProcessing, and then double-click DataTranslation.SignalProcessing. You can select any of the component classes to see its methods and properties.


Using the Example Programs

[image]

Signal Processing Component Library for .NET Documentation
Using the Example Programs
Send Feedback

To help you understand more about using the components included in the Signal Processing Component Library for .NET, the example programs, listed in the table below, are provided in the following directories:

For 32-bit systems:

C:\Program Files\Data Translation\Signal Processing Library\DotNet\Examples

For 64-bit systems:

C:\Program Files (x86)\Data Translation\Signal Processing Library\DotNet\Examples

Example Programs

Example Type | Example Name | Example Description
C# and Visual Basic for .NET | SingleFFTExample | Performs a single-channel FFT operation on time-domain data and plots the result as a real value. You can either acquire the time-domain data from a Data Translation DT-Open Layers device or open a file of time-domain data before performing the single-channel FFT operation.
C# and Visual Basic for .NET | DualFFTExample | Performs a two-channel FFT operation on response and reference time-domain data, and plots the spectrum amplitude of the complex result. You can either acquire the time-domain data for the reference and response channels from a Data Translation DT-Open Layers device or open two files of time-domain data (one file of reference data and one file or response data) before performing the two-channel FFT operation.
C# and Visual Basic for .NET | SignalMetricsExample | Calculates IBF, THD, SFDR, SINAD, ENOB, and SNR values for the specified time-domain data and plots the resulting FFT spectrum frequencies and FFT data. You can either acquire the time-domain data from a Data Translation DT-Open Layers device or open a file of time-domain data before calculating the signal metrics.
Note

To make using the example programs easier, the files sine_data_1024_1.txt and sine_data_1024_2.txt are provided in the Examples directory. These files contain 1024 samples of time-domain data.


Distributing Your Program

[image]

Signal Processing Component Library for .NET Documentation
Distributing Your Program
Send Feedback
Note

Ensure that your program was built with a licensed version of the Signal Processing Component Library for .NET, as you cannot distribute a program that was built with the evaluation version of the component library.

For run-time licensing to work correctly on your customer's system, the SingleChannelFFT, DualChannelFFT, and SignalMetrics components must have been dragged on to the form from the toolbox, and not created in code.

Once the license is entered, open and save any forms that use the SingleChannelFFT, DualChannelFFT, or SignalMetrics components to ensure that the license takes effect before distributing your program.

To distribute your program, perform the following steps:

  1. Copy the file DataTranslation.SignalProcessing.dll to the Windows\Assembly folder or to the folder that contains the executable version of your program.

    You can find this file in following directory:

    For 32-bit systems:

    C:\Program Files\Data Translation\Signal Processing Library\Redistribution

    For 64-bit systems:

    C:\Program Files (x86)\Data Translation\Signal Processing Library\Redistribution

  2. From the Redistribution folder, copy the file listed in the following table to appropriate folder. The file that you copy and its location depend on the target machine and the platform on which you built your program to run.

    Target Machine

    If Program Was Built to Run on the X86 Platform

    If Program Was Built to Run on the X64 Platform

    If Program Was Built to Run on the AnyCPU Platform

    32-Bit Windows

    Copy the file fftw 32 bit\libfftw3-3.dll to the Windows\System32 directory.

    Not applicable.

    Copy the file fftw 32 bit\libfftw3-3.dll to the Windows\System32 directory.

    64-Bit Windows

    Copy the file fftw 32 bit\libfftw3-3.dll to the Windows\SysWOW64 directory.

    Copy the file fftw 64 bit\libfftw3-3.dll to the Windows\System32 directory.

    Copy the file fftw 64 bit\libfftw3-3.dll to the Windows\System32 directory.

  3. Ensure that any Data Translation devices that are used by your program, if applicable, along with their device drivers are installed on the target machine.

Note

The file DataTranslation.SignalProcessing.dll can be distributed royalty-free.


Using the Signal Processing Component Library for .NET

[image]

Signal Processing Component Library for .NET Documentation
Using the Signal Processing Component Library for .NET
Send Feedback
  • Importing the Namespace for the Library
  • Performing a Single-Channel FFT Operation
  • Performing a Two-Channel FFT Operation
  • Calculating Signal Metrics


Importing the Namespace for the Library

[image]

Signal Processing Component Library for .NET Documentation
Importing the Namespace for the Library
Send Feedback

To use any of the components in the Signal Processing Component Library for .NET in code, you first need to import the namespace of the component library in your program, as follows:

C# Copy image Copy
using DataTranslation.SignalProcessing
Visual Basic Copy image Copy
Imports DataTranslation.SignalProcessing


Performing a Single-Channel FFT Operation

[image]

Signal Processing Component Library for .NET Documentation
Performing a Single-Channel FFT Operation
Send Feedback

To perform a single-channel FFT operation, perform the following steps:

1. Set up the Parameters.

2. Compute the Single-Channel FFT.

3. Access the Results.

For more information, see the Example Code at the end of this topic.

Set Up the Parameters

Once you have dragged the SingleChannelFFT component on to your form, perform the following steps to set up the parameters for a single-channel FFT operation:

Note

You can set the properties either interactively using the Property window or in code.

  1. Specify the FFT size using the FFTSize property.

  2. Specify the sampling frequency per channel using the SamplingFrequency property.

  3. Specify the SingleChannelSpectrumFunction to apply using the SpectrumFunction property.

  4. Specify the WindowType using the Window property.

  5. If you are using the Exponential window type, specify the value (between 0 and 1) to which the signal is decayed at the end of the data using the ExpWindowFinalValue property.

  6. If you are using the CosineTaper window type, specify the percentage of the period in which the signal comes through unaltered before the signal ends are smoothed to zero using the CosineTaperPercent property.

  7. If you are using the Force window type, specify the percentage of the period at which the rectangular window starts using the ForceWindowStartPercent property. Then, specify the percentage of the period at which the rectangular window ends using the ForceWindowEndPercent property.

  8. Specify the ScalingType using the ScalingType property.

  9. If you are using dB scaling, specify the reference value using the DbReferenceValue property.

  10. Specify the ScalingValue using the ScalingValue property.

  11. Specify the IntegrationType using the IntegrationType property.

  12. Specify the threshold value that is used to eliminate erroneous values in Phase calculations using the PhaseNoiseThreshold property.

Compute the Single-Channel FFT

To compute the single-channel FFT and return the result as an array of real values, call the ComputeFFT(array<Double>[]()[][]) method.

To compute the single-channel FFT and return the the detailed results of the operation, including the phase, windowed data, real result, and complex result in a FFTResultSingle object, call the ComputeFFTDetailed(array<Double>[]()[][]) method.

Access the Results

If you used the ComputeFFT(array<Double>[]()[][]) method to return an array of real values, no additional steps are required. You can use the real results directly.

If you used the ComputeFFTDetailed(array<Double>[]()[][]) method to return the result and intermediate data, perform the following steps to access the results:

  1. To access the complex processed FFT data, use the ComplexProcessedResult property.

  2. To access the phase data, use the Phase property.

  3. To access the complex, normalized, unprocessed FFT data, use the ComplexUnprocessedResult property.

  4. To access the FFT data as real values use the RealResult property.

  5. To access the result of applying the specified window to the time-domain source data, use the WindowedData property.

Example Code

C# Copy image Copy
//Sample code
using DataTranslation.SignalProcessing;

// Set the FFT Size. The number of spectral lines will be 1/2 this number.
mSingleFFT.FFTParameters.FFTSize = 1024;

// Set the Sampling Frequency
mSingleFFT.FFTParameters.SamplingFrequency = 5000;

// Set the Spectrum function to perform
mSingleFFT.FFTParameters.SpectrumFunction = SingleChannelSpectrumFunction.AutoSpectrum;

// Set the Window parameters
mSingleFFT.FFTParameters.Window.WindowType = WindowType.Hanning;

// Some Window types have additional parameters...
// If you are using a Cosine Taper window type, set the CosineTaperPercent property
if (mSingleFFT.FFTParameters.Window.WindowType == WindowType.CosineTaper)
     mSingleFFT.FFTParameters.Window.CosineTaperPercent = 50.0;

// If you are using a Force window type, set the ForceWindowStartPercent and ForceWindowEndPercent properties
else if (mSingleFFT.FFTParameters.Window.WindowType == WindowType.Force)
{
     mSingleFFT.FFTParameters.Window.ForceWindowStartPercent = 10.0;
     mSingleFFT.FFTParameters.Window.ForceWindowEndPercent = 90.0;
}
// If you are using an Exponential window type, set the ExpWindowFinalValue property
else if (mSingleFFT.FFTParameters.Window.WindowType == WindowType.Exponential)
     mSingleFFT.FFTParameters.Window.ExpWindowFinalValue = 0.1;

// Set the Scaling Type
mSingleFFT.FFTParameters.ScalingType = ScalingType.Linear;

// If you are using dB Scaling, set the DbReferenceValue property
if (mSingleFFT.FFTParameters.ScalingType == ScalingType.db)
  mSingleFFT.FFTParameters.DbReferenceValue = 10.0;

// Set the Scaling Value
mSingleFFT.FFTParameters.ScalingValue = ScalingValue.Peak;

// Set the Integration Type
mSingleFFT.FFTParameters.IntegrationType = IntegrationType.None;

// Set the Phase Noise Threshold Value
mSingleFFT.FFTParameters.PhaseNoiseThreshold = 0.000001;
.
.
.
FFTResultSingle fftResult = null;
try
{
   // Compute the FFT and return the result and intermediate data in a variable of type FFTResultSingle
   fftResult = mSingleFFT.ComputeFFTDetailed(buf);
}
catch (Exception ex)
{
    MessageBox.Show("Error computing FFT: " + ex.Message);
    throw;
}

return fftResult;

// Access the FFT results
result = fftResult.RealResult;
result = fftResult.ComplexProcessedResult;
result = fftResult.ComplexUnprocessedResult;
result = fftResult.Phase;
result = fftResult.WindowedData;

Visual Basic Copy image Copy
'Sample code
Imports DataTranslation.SignalProcessing

' Set the FFT size. The number of spectral lines will be 1/2 this number
mSingleFFT.FFTParameters.FFTSize = 1024

' Set the sampling frequency
mSingleFFT.FFTParameters.SamplingFrequency = 5000

' Set the spectrum function to perform
mSingleFFT.FFTParameters.SpectrumFunction = SingleChannelSpectrumFunction.AutoSpectrum

' Set the Window parameters
mSingleFFT.FFTParameters.Window.WindowType = Hanning

' Some Window types have additional parameters...

' If you are using a Cosine Taper window type, set the CosineTaperPercent property
If mSingleFFT.FFTParameters.Window.WindowType = WindowType.CosineTaper Then
   mSingleFFT.FFTParameters.Window.CosineTaperPercent = 50.0

' If you are using a Force window type, set the ForceWindowStartPercent and ForceWindowEndPercent properties
ElseIf mSingleFFT.FFTParameters.Window.WindowType = WindowType.Force Then
   mSingleFFT.FFTParameters.Window.ForceWindowStartPercent = 10.0
   mSingleFFT.FFTParameters.Window.ForceWindowEndPercent = 90.0

' If you are using an Exponential window type, set the ExpWindowFinalValue property
ElseIf mSingleFFT.FFTParameters.Window.WindowType = WindowType.Exponential Then
    mSingleFFT.FFTParameters.Window.ExpWindowFinalValue = 0.1
End If

' Set the Scaling Type
mSingleFFT.FFTParameters.ScalingType = ScalingType.Linear

' Set the Scaling Value
mSingleFFT.FFTParameters.ScalingValue = ScalingValue.Peak

' If you are using dB Scaling, set the DbReferenceValue property
If mSingleFFT.FFTParameters.ScalingType = ScalingType.db Then
   mSingleFFT.FFTParameters.DbReferenceValue = 10.0
End If

' Set the Integration Type
mSingleFFT.FFTParameters.IntegrationType = IntegrationType.None

' Set the Phase Noise Threshold Value
mSingleFFT.FFTParameters.PhaseNoiseThreshold = 0.000001
.
.
.
Dim fftResult As FFTResultSingle = Nothing
Try
  ' Compute the FFT and return the result and intermediate data in a variable of type FFTResultSingle
  fftResult = mSingleFFT.ComputeFFTDetailed(buf)

Catch ex As Exception
  MessageBox.Show("Error computing FFT: " & ex.Message)
  Throw

End Try

Return fftResult

'Access the FFT results
result = fftResult.RealResult
result = fftResult.ComplexProcessedResult
result = fftResult.ComplexUnprocessedResult
result = fftResult.Phase
result = fftResult.WindowedData


Performing a Two-Channel FFT Operation

[image]

Signal Processing Component Library for .NET Documentation
Performing a Two-Channel FFT Operation
Send Feedback

To perform two-channel FFT operations, perform the following steps:

1. Set up the Parameters.

2. Compute the Two-Channel FFT.

3. Access the Results.

For more information, see the Example Code at the end of this topic.

Set Up the Parameters

Once you have dragged the DualChannelFFT component on to your form, perform the following steps to set up the parameters for a two-channel FFT operation:

Note

You can set the properties either interactively using the Property window or in code.

  1. Specify the FFT size using the FFTSize property.

  2. Specify the sampling frequency per channel using the SamplingFrequency property.

  3. Specify the DualChannelSpectrumFunction to apply using the SpectrumFunction property.

  4. If you are using the FRF spectrum function, specify the FRFMode using the FRFMode property.

    Then, specify the FRFEstimator using the FRFEstimator property.

  5. If you are using the Cross spectrum function, specify the CrossSpectrumFunction type using the Cross property.

  6. For the response channel, specify the WindowType to apply to the time-domain source data using the ResponseWindow property.

  7. If you are using the Exponential window type for the response channel, specify the value (between 0 and 1) to which the signal is decayed at the end of the data using the ExpWindowFinalValue property.

  8. If you are using the CosineTaper window type for the response channel, specify the percentage of the period in which the signal comes through unaltered before the signal ends are smoothed to zero using the CosineTaperPercent property.

  9. If you are using the Force window type for the response channel, specify the percentage of the period at which the rectangular window starts using the ForceWindowStartPercent property. Then, specify the percentage of the period at which the rectangular window ends using the ForceWindowEndPercent property.

  10. For the reference channel, specify the WindowType to apply to the time-domain source data using the ReferenceWindow property.

  11. If you are using the Exponential window type for the reference channel, specify the value (between 0 and 1) to which the signal is decayed at the end of the data using the ExpWindowFinalValue property.

  12. If you are using the CosineTaper window type for the reference channel, specify the percentage of the period in which the signal comes through unaltered before the signal ends are smoothed to zero using the CosineTaperPercent property.

  13. If you are using the Force window type for the reference channel, specify the percentage of the period at which the rectangular window starts using the ForceWindowStartPercent property. Then, specify the percentage of the period at which the rectangular window ends using the ForceWindowEndPercent property.

  14. Specify the ScalingType using the ScalingType property.

  15. If you are using dB scaling, specify the reference value using the DbReferenceValue property.

  16. Specify the ScalingValue using the ScalingValue property.

  17. For the response channel, specify the IntegrationType using the IntegrationTypeResponse property.

  18. For the reference channel, specify the IntegrationType using the IntegrationTypeReference property.

  19. Specify the threshold value that is used to eliminate erroneous values in Phase calculations using the PhaseNoiseThreshold property.

Compute the Two-Channel FFT

To compute the two-channel FFT and return the result as an array of real values, call the ComputeFFT method.

To compute the two-channel FFT and return the the detailed results of the operation, including the phase, windowed data, real result, complex processed result, and complex unprocessed result in a FFTResultDual object, call the ComputeFFTDetailed method.

Access the Results

If you used the ComputeFFT method to return an array of real values, no additional steps are required. You can use the real results directly.

If you used the ComputeFFTDetailed method to return the result and intermediate data, perform the following steps to access the results:

  1. To access the complex processed FFT data, use the ComplexProcessedResult property.

  2. To access the phase data, use the Phase property.

  3. To access the complex, normalized, unprocessed FFT data for the response channel, use the ComplexUnprocessedResponseResult property.

  4. To access the complex, normalized, unprocessed FFT data for the reference channel, use the ComplexUnprocessedReferenceResult property.

  5. To access the result of applying the specified Window to the time-domain source data of the response channel, use the ResponseWindowedData property.

  6. To access the result of applying the specified Window to the time-domain source data of the reference channel, use the ReferenceWindowedData property.

  7. To access the FFT data as real values, use the RealResult property.

Example Code

C# Copy image Copy
//Sample code
using DataTranslation.SignalProcessing;

// Set the FFT Size. The number of spectral lines will be 1/2 this number.
 mDualFFT.FFTParameters.FFTSize = 1024;

// Set the Sampling Frequency
mDualFFT.FFTParameters.SamplingFrequency = 5000;

// Set the Spectrum function to perform
mDualFFT.FFTParameters.SpectrumFunction = DualChannelSpectrumFunction.AutoSpectrum;

// Set the Window parameters for the response channel
mDualFFT.FFTParameters.ResponseWindow.WindowType = WindowType.Hanning;

// Some Window types have additional parameters...

// If you are using a Cosine Taper window type for the response channel,
set the CosineTaperPercent property
if (mDualFFT.FFTParameters.ResponseWindow.WindowType == WindowType.CosineTaper)
     mDualFFT.FFTParameters.ResponseWindow.CosineTaperPercent = 50.0;

// If you are using a Force window type for the response channel,
set the ForceWindowStartPercent and ForceWindowEndPercent properties
else if (mDualFFT.FFTParameters.ResponseWindow.WindowType == WindowType.Force)
{
    mDualFFT.FFTParameters.ResponseWindow.ForceWindowStartPercent = 10.0;
    mDualFFT.FFTParameters.ResponseWindow.ForceWindowEndPercent = 90.0;
}

// If you are using an Exponential window type for the response channel,
set the ExpWindowFinalValue property
else if (mDualFFT.FFTParameters.ResponseWindow.WindowType == WindowType.Exponential)
     mDualFFT.FFTParameters.ResponseWindow.ExpWindowFinalValue = 0.1;

// Set the Window parameters for the reference channel
mDualFFT.FFTParameters.ReferenceWindow.WindowType = WindowType.Hamming;

// If you are using a Cosine Taper window type for the reference channel,
set the CosineTaperPercent property
if (mDualFFT.FFTParameters.ReferenceWindow.WindowType == WindowType.CosineTaper)
     mDualFFT.FFTParameters.ReferenceWindow.CosineTaperPercent = 50.0;

// If you are using a Force window type for the reference channel,
set the ForceWindowStartPercent and ForceWindowEndPercent properties
else if (mDualFFT.FFTParameters.ReferenceWindow.WindowType == WindowType.Force)
{
    mDualFFT.FFTParameters.ReferenceWindow.ForceWindowStartPercent = 10.0;
    mDualFFT.FFTParameters.ReferenceWindow.ForceWindowEndPercent = 90.0;
}

// If you are using an Exponential window type for the reference channel,
set the ExpWindowFinalValue property
else if (mDualFFT.FFTParameters.ReferenceWindow.WindowType == WindowType.Exponential)
     mDualFFT.FFTParameters.ReferenceWindow.ExpWindowFinalValue = 0.1;

// Set the Scaling Type
mDualFFT.FFTParameters.ScalingType = ScalingType.Linear;

// If you are using dB Scaling, set the DbReferenceValue property
if (mDualFFT.FFTParameters.ScalingType == ScalingType.db)
  mDualFFT.FFTParameters.DbReferenceValue = 10.0;

// Set the Scaling Value
mDualFFT.FFTParameters.ScalingValue = ScalingValue.Peak;

// Set the Integration Type for the response channel
mDualFFT.FFTParameters.IntegrationTypeResponse = IntegrationTypeResponse.None;

// Set the Integration Type for the reference channel
mDualFFT.FFTParameters.IntegrationTypeReference = IntegrationTypeReference.None;

// Set the Phase Noise Threshold Value
mDualFFT.FFTParameters.PhaseNoiseThreshold = 0.000001;
.
.
.
FFTResultDual fftResult = null;
try
{
   // Compute the FFT using a buffer of reference time-domain data and a buffer of response time-domain data
   fftResult = mDualFFT.ComputeFFTDetailed(refbuf, respbuf);
}
catch (Exception ex)
{
    MessageBox.Show("Error computing FFT: " + ex.Message);
    throw;
}
return fftResult;

// Access the FFT results
result = fftResult.RealResult;
result = fftResult.ComplexProcessedResult;
result = fftResult.ComplexUnprocessedReferenceResult;
result = fftResult.ComplexUnprocessedResponseResult;
result = fftResult.Phase;
result = fftResult.ReferenceWindowedData;
result = fftResult.ResponseWindowedData;

Visual Basic Copy image Copy
'Sample code
Imports DataTranslation.SignalProcessing

' Set the FFT size. The number of spectral lines will be 1/2 this number
mDualFFT.FFTParameters.FFTSize = 1024

' Set the Sampling Frequency
mDualFFT.FFTParameters.SamplingFrequency = 5000

' Set the Spectrum function to perform
mDualFFT.FFTParameters.SpectrumFunction = DualChannelSpectrumFunction.AutoSpectrum

' Set the Window parameters for the response channel
mDualFFT.FFTParameters.ResponseWindow.WindowType = WindowType.Hanning

' Some Window types have additional parameters...

' If you are using a Cosine Taper window type for the response channel,
set the CosineTaperPercent property
If DualFFT.FFTParameters.ResponseWindow.WindowType = WindowType.CosineTaper Then
     mDualFFT.FFTParameters.ResponseWindow.CosineTaperPercent = 50.0

' If you are using a Force window type for the response channel,
set the ForceWindowStartPercent and ForceWindowEndPercent properties
ElseIf mDualFFT.FFTParameters.ResponseWindow.WindowType = WindowType.Force Then
    mDualFFT.FFTParameters.ResponseWindow.ForceWindowStartPercent = 10.0
    mDualFFT.FFTParameters.ResponseWindow.ForceWindowEndPercent = 90.0

' If you are using an Exponential window type for the response channel,
set the ExpWindowFinalValue property
ElseIf mDualFFT.FFTParameters.ResponseWindow.WindowType = WindowType.Exponential Then
     mDualFFT.FFTParameters.ResponseWindow.ExpWindowFinalValue = 0.1

' Set the Window parameters for the reference channel
mDualFFT.FFTParameters.ReferenceWindow.WindowType = WindowType.Hamming

' Some Window types have additional parameters...

' If you are using a Cosine Taper window type for the reference channel,
set the CosineTaperPercent property
If mDualFFT.FFTParameters.ReferenceWindow.WindowType = WindowType.CosineTaper Then
     mDualFFT.FFTParameters.ReferenceWindow.CosineTaperPercent = 50.0

' If you are using a Force window type for the reference channel,
set the ForceWindowStartPercent and ForceWindowEndPercent properties
ElseIf (mDualFFT.FFTParameters.ReferenceWindow.WindowType = WindowType.Force
    mDualFFT.FFTParameters.ReferenceWindow.ForceWindowStartPercent = 10.0
    mDualFFT.FFTParameters.ReferenceWindow.ForceWindowEndPercent = 90.0

' If you are using an Exponential window type for the reference channel,
set the ExpWindowFinalValue property
ElseIf mDualFFT.FFTParameters.ReferenceWindow.WindowType = WindowType.Exponential Then
     mDualFFT.FFTParameters.ReferenceWindow.ExpWindowFinalValue = 0.1;
End If

' Set the Scaling Type
mDualFFT.FFTParameters.ScalingType = ScalingType.Linear

' If you are using dB Scaling, set the DbReferenceValue property
If mDualFFT.FFTParameters.ScalingType == ScalingType.db Then
  mDualFFT.FFTParameters.DbReferenceValue = 10.0
End If

' Set the Scaling Value
mDualFFT.FFTParameters.ScalingValue = ScalingValue.Peak

' Set the Integration Type for the response channel
mDualFFT.FFTParameters.IntegrationTypeResponse = IntegrationTypeResponse.None

' Set the Integration Type for the reference channel
mDualFFT.FFTParameters.IntegrationTypeReference = IntegrationTypeReference.None

' Set the Phase Noise Threshold Value
mDualFFT.FFTParameters.PhaseNoiseThreshold = 0.000001
.
.
.
Dim fftResult As FFTResultDual = Nothing
Try
  ' Compute the FFT using a buffer of reference time-domain data and a buffer of response time-domain data
   ftResult = mDualFFT.ComputeFFTDetailed(refbuf, respbuf)

Catch ex As Exception
   MessageBox.Show("Error computing FFT: " & ex.Message)
   Throw

End Try
Return fftResult

' Access the FFT results
result = fftResult.RealResult
result = fftResult.ComplexProcessedResult
result = fftResult.ComplexUnprocessedReferenceResult
result = fftResult.ComplexUnprocessedResponseResult
result = fftResult.Phase
result = fftResult.ReferenceWindowedData
result = fftResult.ResponseWindowedData


Calculating Signal Metrics

[image]

Signal Processing Component Library for .NET Documentation
Calculating Signal Metrics
Send Feedback

To calculate signal metrics on time-domain data, perform the following steps:

1. Set up the Parameters.

2. Compute the Signal Metrics and Handle Exceptions.

3. Access the Results.

For more information, see the Example Code at the end of this topic.

Set Up the Parameters

Once you have dragged the SignalMetrics component on to your form, perform the following steps to set up the parameters for a signal metrics calculation:

Note

You can set the properties either interactively using the Property window or in code.

  1. Specify the number of data points to use when generating FFTs using the FFTSize property.

  2. Specify the per channel sampling frequency of the time-domain source data using the SamplingFrequency property.

  3. Specify the full-scale range of the device from which the data was acquired using the FullScaleRange property.

  4. Specify the minimum number of harmonics that are required for the THD calculation using the RequiredNumberOfTHDHarmonics property.

Compute the Signal Metrics and Handle Exceptions

Compute the signal metrics and return the results in a SignalMetricsResult object using the ComputeMetrics method.

Handle exceptions using the SignalProcessingException class.

Access the Results

To access the results of a signal metrics calculation, perform the following steps:

  1. To access the IBF value, in dB, use the IBF property.

  2. To access the THD value, use the dB field of the THD structure to return the value in dB, or the Percent field of the THD structure to return the value in percent.

  3. To access the SFDR value, in dB, use the SFDR property.

  4. To access the SINAD value, in dB, use the SINAD property.

  5. To access the ENOB value, in bits, use the ENOB property.

  6. To access the SNR value, in dB, use the SNR property.

  7. To access the FFT magnitude data for the FFT AutoSpectrum calculation that is done as a precursor to the signal metrics calculations, use the FFTResultData property.

  8. To access the per bin spectrum frequencies for the FFT AutoSpectrum calculation that is done as a precursor to the signal metrics calculations, use the FFTResultSpectrumFrequencies property.

Example Code

C# Copy image Copy
//Sample code
using DataTranslation.SignalProcessing;

// Set the FFT Size. The number of spectral lines will be 1/2 this number.
mSignalMetrics.FFTSize = 1024;

// Set the Sampling Frequency
mSignalMetrics.SamplingFrequency = 5000;

// Set the Full-Scale Range
mSignalMetrics.FullScaleRange = 20;

// Set the Required Number of Harmonics for THD Calculations
mSignalMetrics.RequiredNumberOfTHDHarmonics = 5;
.
.
.
SignalMetricsResult metricsResult = null;
try
{
  // Calculate the signal metrics
  metricsResult = mSignalMetrics.ComputeMetrics(buf);
}
// Check for signal processing exceptions
catch (SignalProcessingException ex)
{
  statusBarPanel.Text = ex.Message;
  FundamentalOutOfRange = ex.FundamentalBinOutOfRange;
}
catch (Exception ex)
{
   MessageBox.Show("Error computing FFT: " + ex.Message);
   throw;
}

return metricsResult;

//Get the results
IBF_Value = metricsResult.IBF;
THD_Value_dB = metricsResult.THD.dB;
THD_Value_Percent = metricsResult.THD.Percent;
SFDR_Value = metricsResult.SFDR;
SINAD_Value = metricsResult.SINAD;
ENOB_Value = metricsResult.ENOB;
SNR_Value = metricsResult.SNR;
SpectrumFrequencies = metricsResult.FFTResultSpectrumFrequencies;
ResultData = metricsResult.FFTResultData;

Visual Basic Copy image Copy
'Sample code
Imports DataTranslation.SignalProcessing

' Set the FFT Size. The number of spectral lines will be 1/2 this number.
mSignalMetrics.FFTSize = 1024

' Set the Sampling Frequency
mSignalMetrics.SamplingFrequency = 5000

' Set the Full-Scale Range
mSignalMetrics.FullScaleRange = 20

' Set the Required Number of Harmonics for THD calculations
mSignalMetrics.RequiredNumberOfTHDHarmonics = 5
.
.
.
Dim metricsResult As SignalMetricsResult = Nothing
Try
  ' Calculate the signal metrics
  metricsResult = mSignalMetrics.ComputeMetrics(buf)

' Check for signal processing exceptions
Catch ex As SignalProcessingException
  StatusBarPanel.Text = ex.Message
  FundamentalOutOfRange = ex.FundamentalBinOutOfRange

Catch ex As Exception

  MessageBox.Show("Error computing FFT: " & ex.Message)

  Throw
End Try

Return metricsResult

'Get the results
IBF_Value = metricsResult.IBF
THD_Value_Percent = metricsResult.THD.Percent
THD_Value_dB = metricsResult.THD.dB
SFDR_Value = metricsResult.SFDR
SINAD_Value = metricsResult.SINAD
ENOB_Value = metricsResult.ENOB
SNR_Value = metricsResult.SNR
SpectrumFrequencies = metricsResult.FFTResultSpectrumFrequencies
ResultData = metricsResult.FFTResultData


About Signal Metrics

[image]

Signal Processing Component Library for .NET Documentation
About Signal Metrics
Send Feedback
  • Understanding IBF
  • Understanding THD
  • Understanding SFDR
  • Understanding SINAD
  • Understanding ENOB
  • Understanding SNR


Understanding IBF

[image]

Signal Processing Component Library for .NET Documentation
Understanding IBF
Send Feedback

Use the IBF property to return the Input Below Full-scale (IBF) value, in dB. IBF represents the level of the main signal component relative to the full-scale voltage, as shown below.

IBF is computed using the following equation:

where Vs is the main signal component and Vf is the full-scale voltage. For example, if a ±1 V sine wave is applied to an analog input channel that is configured for a ±10 V range, IBF is computed as follows:

IMG IBFCalc Ex


Understanding THD

[image]

Signal Processing Component Library for .NET Documentation
Understanding THD
Send Feedback

The THD value, returned in dB and %, represents the level of the harmonic distortion of the specified number of harmonics relative to the main signal component, as shown below.

THD is computed using the following equations:

For dB:

For %:

THD Equation Percent

For example, if a 7.07 VRMS sine wave is applied to an analog input channel that is configured for a ±10 V range and the distortion (first five harmonics) is 14 μVRMS, THD is computed as follows:


Understanding SFDR

[image]

Signal Processing Component Library for .NET Documentation
Understanding SFDR
Send Feedback

The SFDR value, returned in dB, represents the level of the full-scale range to the greatest noise or distortion component, as shown below.

SFDR is computed using the following equation:

where Vf is the full-scale range and Va is the greatest noise component.

For example, if the analog input channel is configured for a ±10 V range, and the greatest noise or distortion component is 7.07 VRMS, SFDR is computed as follows:


Understanding SINAD

[image]

Signal Processing Component Library for .NET Documentation
Understanding SINAD
Send Feedback

The SINAD value, returned in dB, represents the level of the main signal component relative to the total noise, VRMS, including harmonics, as shown below:

SINAD is computed using the following equation:

where Vs is the main signal component and Vn+d is the total noise plus distortion.

For example, if a 7.07 VRMS sine wave is applied to an analog input channel that is configured for a ±10 V range and the total noise and harmonics (distortion) is 14.14 μVRMS, SINAD is computed as follows:


Understanding ENOB

[image]

Signal Processing Component Library for .NET Documentation
Understanding ENOB
Send Feedback

The ENOB value, returned in bits, represents the quality of a digitized signal. The input signal is typically sinusoidal and should be near full-scale to properly characterize the A/D converter and/or system. ENOB is computed using the following equation:

For example, if a ±9 V sine wave is applied to an analog input channel that is configured for a ±10 V range and the average noise floor plus distortion (harmonics) is 30 μV peak, the ENOB is computed as follows:


Understanding SNR

[image]

Signal Processing Component Library for .NET Documentation
Understanding SNR
Send Feedback

The SNR value, returned in dB, represents the level of the main signal component relative to the total noise, VRMS, as shown below. Note that harmonics are not included in the noise.

SNR is computed using the following equation:

where Vs is the main signal component and Vn is the total noise.

For example, if a 7.07 VRMS sine wave is applied to an analog input channel that is configured for a ±10 V range and the total noise is 7.07 μVRMS, SNR is computed as follows:


DataTranslation.SignalProcessing Namespace

[image]

Signal Processing Component Library for .NET Documentation
DataTranslation.SignalProcessing Namespace
Send Feedback
A collection of classes and enumerations that provide a programming interface for performing signal processing operations.

Classes

 | Class | Description
Public class | DualChannelFFT | The DualChannelFFT class provides the properties and methods for performing a two-channel FFT operation.
Public class | FFTBase | The FFTBase class provides properties and methods for returning spectrum frequency information.
Public class | FFTParamsBase | The FFTParams class provides properties that are used to specify parameters for FFT calculations.
Public class | FFTParamsDual | The FFTParamsDual class provides properties that are used to specify parameters for a two-channel FFT operation.
Public class | FFTParamsSingle | The FFTParamsSingle class provides properties that are used to specify parameters for a single-channel FFT operation.
Public class | FFTResultDual | The FFTResultDual class contains the result of a two-channel FFT operation.
Public class | FFTResultSingle | The FFTResultSingle class contains the result of a single-channel FFT operation.
Public class | SignalMetrics | The SignalMetrics class provides the properties and methods for calculating metrics (IBF, THD, SFDR, SINAD, ENOB, and SNR) on the time-domain data.
Public class | SignalMetricsResult | The SignalMetricsResult class contains the metrics (IBF, THD, SFDR, SINAD, ENOB, and SNR) that were calculated on the data using the SignalMetrics class.
Public class | SignalProcessingException | The SignalProcessingException class provides properties, fields, and methods that are used to handle exceptions when calculating signal metrics.
Public class | SingleChannelFFT | The SingleChannelFFT class provides the properties and methods for performing a single-channel FFT operation.
Public class | Window | The Window class provides properties for configuring the time-domain windowing functions.

Structures

 | Structure | Description
Public structure | THD | Structure that contains the Total Harmonic Distortion results.

Enumerations

 | Enumeration | Description
Public enumeration | CrossSpectrumFunction | Cross Spectrum function type. This enumeration is used by the CrossSpectrumFunction property.
Public enumeration | DualChannelSpectrumFunction | Spectrum function to perform for a two-channel FFT operation. This enumeration is used by the SpectrumFunction property.
Public enumeration | FRFEstimator | FRF estimator type for the FRF function. This enumeration is used by the FRFEstimator property.
Public enumeration | FRFMode | FRF mode for the FRF function. Based on the specified mode, the Signal Processing Library for .NET sets the integration type for the response channel accordingly. This enumeration is used by the FRFMode property.
Public enumeration | IntegrationType | Integration type for the FFT operation. This enumeration is used by the IntegrationType, IntegrationTypeReference, and IntegrationTypeResponse properties.
Public enumeration | ScalingType | Scaling type for the resulting data. This enumeration is used by the ScalingType property.
Public enumeration | ScalingValue | Scaling value of the resulting data relative to the input signal. This enumeration is used by the ScalingValue property.
Public enumeration | SingleChannelSpectrumFunction | Spectrum function to perform for a single-channel FFT operation. This enumeration is used by the SpectrumFunction property.
Public enumeration | WindowType | The windowing type to apply to time-domain source data. This enumeration is used by the WindowType property.


CrossSpectrumFunction Enumeration

[image]

Signal Processing Component Library for .NET Documentation
CrossSpectrumFunction Enumeration
See Also Send Feedback
Cross Spectrum function type. This enumeration is used by the CrossSpectrumFunction property.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public enum CrossSpectrumFunction
Visual Basic
Public Enumeration CrossSpectrumFunction

Members

Member name | Value | Description
CrossPowerSpectrum | 0 | A building block used in FRF and other more advanced functions. The cross- power spectrum is defined as the product of the complex Fourier spectrum of the response channel multiplied by the complex conjugate of the Fourier spectrum of the reference channel.
CrossPSD | 1 | (Cross Power Spectral Density) The distribution of power per unit frequency.

See Also

DataTranslation.SignalProcessing Namespace


DualChannelFFT Class

[image]

Signal Processing Component Library for .NET Documentation
DualChannelFFT Class
Members See Also Send Feedback
The DualChannelFFT class provides the properties and methods for performing a two-channel FFT operation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public class DualChannelFFT : FFTBase
Visual Basic
Public Class DualChannelFFT
    Inherits FFTBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
DataTranslation.SignalProcessing..::..FFTBase
DataTranslation.SignalProcessing..::..DualChannelFFT

See Also

DualChannelFFT Members


DualChannelFFT Members

[image] [image]

Signal Processing Component Library for .NET Documentation
DualChannelFFT Members
DualChannelFFT Class Constructors Methods Properties Events See Also Send Feedback

The DualChannelFFT type exposes the following members.

Constructors

 | Name | Description
Public method | DualChannelFFT()()()() | Initializes a new instance of the DualChannelFFT class.
Public method | DualChannelFFT(IContainer) | Initializes a new instance of the DualChannelFFT class.

Methods

 | Name | Description
Public method | ComputeFFT | Computes a two-channel FFT based on the specified parameters and returns the result as an array of real values.
Public method | ComputeFFTDetailed | Computes a two-channel FFT based on the specified parameters and returns the result and intermediate data in a variable of type FFTResultDual.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetSpectrumFrequencyIndex | Returns the bin index of a spectrum frequency. (Inherited from FFTBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | FFTParameters | Returns the parameters that are used in a two-channel FFT calculation.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SpectrumFrequencies | Returns the current bin frequencies for the spectrum. (Inherited from FFTBase.)

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

DualChannelFFT Class


DualChannelFFT Constructor

[image] [image]

Signal Processing Component Library for .NET Documentation
DualChannelFFT Constructor
DualChannelFFT Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DualChannelFFT()()()() | Initializes a new instance of the DualChannelFFT class.
Public method | DualChannelFFT(IContainer) | Initializes a new instance of the DualChannelFFT class.

See Also

DualChannelFFT Class
DualChannelFFT Members


DualChannelFFT Constructor

[image]

Signal Processing Component Library for .NET Documentation
DualChannelFFT Constructor
DualChannelFFT Class See Also Send Feedback
Initializes a new instance of the DualChannelFFT class.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public DualChannelFFT()
Visual Basic
Public Sub New

Remarks

For client run-time licensing to work correctly this constructor should not be called directly. The component must be dragged to the form from the Visual Studio Toolbox.

See Also

DualChannelFFT Class
DualChannelFFT Members
DualChannelFFT Overload


DualChannelFFT Constructor (IContainer)

[image]

Signal Processing Component Library for .NET Documentation
DualChannelFFT Constructor (IContainer)
DualChannelFFT Class See Also Send Feedback
Initializes a new instance of the DualChannelFFT class.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public DualChannelFFT(
    IContainer container
)
Visual Basic
Public Sub New (
    container As IContainer
)

Parameters

container
Type: System.ComponentModel..::..IContainer
The System.ComponentModel.IContainer interface.

Remarks

For client run-time licensing to work correctly this constructor should not be called directly. The component must be dragged to the form from the Visual Studio Toolbox.

See Also

DualChannelFFT Class
DualChannelFFT Members
DualChannelFFT Overload


DualChannelFFT Methods

[image] [image]

Signal Processing Component Library for .NET Documentation
DualChannelFFT Methods
DualChannelFFT Class See Also Send Feedback

The DualChannelFFT type exposes the following members.

Methods

 | Name | Description
Public method | ComputeFFT | Computes a two-channel FFT based on the specified parameters and returns the result as an array of real values.
Public method | ComputeFFTDetailed | Computes a two-channel FFT based on the specified parameters and returns the result and intermediate data in a variable of type FFTResultDual.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetSpectrumFrequencyIndex | Returns the bin index of a spectrum frequency. (Inherited from FFTBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

DualChannelFFT Class


DualChannelFFT.ComputeFFT Method

[image]

Signal Processing Component Library for .NET Documentation
DualChannelFFT..::..ComputeFFT Method
DualChannelFFT Class See Also Send Feedback
Computes a two-channel FFT based on the specified parameters and returns the result as an array of real values.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double[] ComputeFFT(
    double[] referenceData,
    double[] responseData
)
Visual Basic
Public Function ComputeFFT (
    referenceData As Double(),
    responseData As Double()
) As Double()

Parameters

referenceData
Type: array< System..::..Double >[]()[][]
The time-domain input data for the reference channel.
responseData
Type: array< System..::..Double >[]()[][]
The time-domain input data for the response channel.

Return Value

Type: array< Double >[]()[][]
The result of the two-channel FFT operation.

See Also

DualChannelFFT Class
DualChannelFFT Members


DualChannelFFT.ComputeFFTDetailed Method

[image]

Signal Processing Component Library for .NET Documentation
DualChannelFFT..::..ComputeFFTDetailed Method
DualChannelFFT Class See Also Send Feedback
Computes a two-channel FFT based on the specified parameters and returns the result and intermediate data in a variable of type FFTResultDual.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public FFTResultDual ComputeFFTDetailed(
    double[] referenceData,
    double[] responseData
)
Visual Basic
Public Function ComputeFFTDetailed (
    referenceData As Double(),
    responseData As Double()
) As FFTResultDual

Parameters

referenceData
Type: array< System..::..Double >[]()[][]
The time-domain input data for the reference channel.
responseData
Type: array< System..::..Double >[]()[][]
The time-domain input data for the response channel.

Return Value

Type: FFTResultDual
The result of the two-channel FFT operation.

See Also

DualChannelFFT Class
DualChannelFFT Members


DualChannelFFT Properties

[image] [image]

Signal Processing Component Library for .NET Documentation
DualChannelFFT Properties
DualChannelFFT Class See Also Send Feedback

The DualChannelFFT type exposes the following members.

Properties

 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | FFTParameters | Returns the parameters that are used in a two-channel FFT calculation.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SpectrumFrequencies | Returns the current bin frequencies for the spectrum. (Inherited from FFTBase.)

See Also

DualChannelFFT Class


DualChannelFFT.FFTParameters Property

[image]

Signal Processing Component Library for .NET Documentation
DualChannelFFT..::..FFTParameters Property
DualChannelFFT Class See Also Send Feedback
Returns the parameters that are used in a two-channel FFT calculation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public FFTParamsDual FFTParameters { get; }
Visual Basic
Public ReadOnly Property FFTParameters As FFTParamsDual
    Get

Property Value

Type: FFTParamsDual

See Also

DualChannelFFT Class
DualChannelFFT Members


DualChannelFFT Events

[image] [image]

Signal Processing Component Library for .NET Documentation
DualChannelFFT Events
DualChannelFFT Class See Also Send Feedback

The DualChannelFFT type exposes the following members.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

DualChannelFFT Class


DualChannelSpectrumFunction Enumeration

[image]

Signal Processing Component Library for .NET Documentation
DualChannelSpectrumFunction Enumeration
See Also Send Feedback
Spectrum function to perform for a two-channel FFT operation. This enumeration is used by the SpectrumFunction property.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public enum DualChannelSpectrumFunction
Visual Basic
Public Enumeration DualChannelSpectrumFunction

Members

Member name | Value | Description
FRF | 0 | An FRF function represents the complex ratio between the output (response) signal and the input (reference) signal as a function of frequency.
Cross | 1 | A Cross spectrum function is a two-channel display function of the frequency domain. It contains a building block that is used in FRF and other more advanced functions. It is the product of the complex Fourier spectrum of the reference channel multiplied by the complex conjugate of the Fourier spectrum of the response channel.

See Also

DataTranslation.SignalProcessing Namespace

Send comments on this topic to info@datx.com

Copyright © 2013 by Data Translation, Inc.


FFTBase Class

[image]

Signal Processing Component Library for .NET Documentation
FFTBase Class
Members See Also Send Feedback
The FFTBase class provides properties and methods for returning spectrum frequency information.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public abstract class FFTBase : Component
Visual Basic
Public MustInherit Class FFTBase
    Inherits Component

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
DataTranslation.SignalProcessing..::..FFTBase
DataTranslation.SignalProcessing..::..DualChannelFFT
DataTranslation.SignalProcessing..::..SingleChannelFFT

See Also

FFTBase Members


FFTBase Members

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTBase Members
FFTBase Class Methods Properties Events See Also Send Feedback

The FFTBase type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetSpectrumFrequencyIndex | Returns the bin index of a spectrum frequency.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SpectrumFrequencies | Returns the current bin frequencies for the spectrum.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

FFTBase Class


FFTBase Methods

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTBase Methods
FFTBase Class See Also Send Feedback

The FFTBase type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetSpectrumFrequencyIndex | Returns the bin index of a spectrum frequency.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

FFTBase Class


FFTBase.GetSpectrumFrequencyIndex Method

[image]

Signal Processing Component Library for .NET Documentation
FFTBase..::..GetSpectrumFrequencyIndex Method
FFTBase Class See Also Send Feedback
Returns the bin index of a spectrum frequency.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public int GetSpectrumFrequencyIndex(
    double freq
)
Visual Basic
Public Function GetSpectrumFrequencyIndex (
    freq As Double
) As Integer

Parameters

freq
Type: System..::..Double
The spectrum frequency.

Return Value

Type: Int32
The bin index of the specified frequency.

See Also

FFTBase Class
FFTBase Members


FFTBase Properties

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTBase Properties
FFTBase Class See Also Send Feedback

The FFTBase type exposes the following members.

Properties

 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SpectrumFrequencies | Returns the current bin frequencies for the spectrum.

See Also

FFTBase Class


FFTBase.SpectrumFrequencies Property

[image]

Signal Processing Component Library for .NET Documentation
FFTBase..::..SpectrumFrequencies Property
FFTBase Class See Also Send Feedback
Returns the current bin frequencies for the spectrum.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double[] SpectrumFrequencies { get; }
Visual Basic
Public ReadOnly Property SpectrumFrequencies As Double()
    Get

Property Value

Type: array< Double >[]()[][]

See Also

FFTBase Class
FFTBase Members


FFTBase Events

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTBase Events
FFTBase Class See Also Send Feedback

The FFTBase type exposes the following members.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

FFTBase Class


FFTParamsBase Class

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsBase Class
Members See Also Send Feedback
The FFTParams class provides properties that are used to specify parameters for FFT calculations.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public abstract class FFTParamsBase : Component
Visual Basic
Public MustInherit Class FFTParamsBase
    Inherits Component

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
DataTranslation.SignalProcessing..::..FFTParamsBase
DataTranslation.SignalProcessing..::..FFTParamsDual
DataTranslation.SignalProcessing..::..FFTParamsSingle

See Also

FFTParamsBase Members


FFTParamsBase Members

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTParamsBase Members
FFTParamsBase Class Methods Properties Events See Also Send Feedback

The FFTParamsBase type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DbReferenceValue | Gets and sets the reference value that is used when dB scaling is specified.
Public property | FFTSize | Gets and sets the number of data points to use when generating FFTs.
Public property | PhaseNoiseThreshold | Gets and sets the phase noise threshold value.
Public property | SamplingFrequency | Gets and sets the sampling frequency per channel for the time-domain source data.
Public property | ScalingType | Gets and sets the ScalingType for the FFT calculation.
Public property | ScalingValue | Gets and sets the ScalingValue for the FFT calculation.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

FFTParamsBase Class


FFTParamsBase Methods

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTParamsBase Methods
FFTParamsBase Class See Also Send Feedback

The FFTParamsBase type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

FFTParamsBase Class


FFTParamsBase Properties

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTParamsBase Properties
FFTParamsBase Class See Also Send Feedback

The FFTParamsBase type exposes the following members.

Properties

 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DbReferenceValue | Gets and sets the reference value that is used when dB scaling is specified.
Public property | FFTSize | Gets and sets the number of data points to use when generating FFTs.
Public property | PhaseNoiseThreshold | Gets and sets the phase noise threshold value.
Public property | SamplingFrequency | Gets and sets the sampling frequency per channel for the time-domain source data.
Public property | ScalingType | Gets and sets the ScalingType for the FFT calculation.
Public property | ScalingValue | Gets and sets the ScalingValue for the FFT calculation.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

FFTParamsBase Class


FFTParamsBase.DbReferenceValue Property

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsBase..::..DbReferenceValue Property
FFTParamsBase Class See Also Send Feedback
Gets and sets the reference value that is used when dB scaling is specified.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double DbReferenceValue { get; set; }
Visual Basic
Public Property DbReferenceValue As Double
    Get
    Set

Property Value

Type: Double

See Also

FFTParamsBase Class
FFTParamsBase Members


FFTParamsBase.FFTSize Property

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsBase..::..FFTSize Property
FFTParamsBase Class See Also Send Feedback
Gets and sets the number of data points to use when generating FFTs.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public int FFTSize { get; set; }
Visual Basic
Public Property FFTSize As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

The value of FFTSize must be a power of 2. The resultant number of spectral lines is half the value of FFTSize.

See Also

FFTParamsBase Class
FFTParamsBase Members


FFTParamsBase.PhaseNoiseThreshold Property

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsBase..::..PhaseNoiseThreshold Property
FFTParamsBase Class See Also Send Feedback
Gets and sets the phase noise threshold value.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double PhaseNoiseThreshold { get; set; }
Visual Basic
Public Property PhaseNoiseThreshold As Double
    Get
    Set

Property Value

Type: Double

Remarks

When computing Phase, very small values in the complex FFT data can occur due to floating-point rounding errors. These values can produce erroneous Phase results. To eliminate these errors, you can set the phase noise threshold value. During the Phase computation, any real or imaginary value that falls below this threshold is set to zero.

See Also

FFTParamsBase Class
FFTParamsBase Members


FFTParamsBase.SamplingFrequency Property

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsBase..::..SamplingFrequency Property
FFTParamsBase Class See Also Send Feedback
Gets and sets the sampling frequency per channel for the time-domain source data.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double SamplingFrequency { get; set; }
Visual Basic
Public Property SamplingFrequency As Double
    Get
    Set

Property Value

Type: Double

See Also

FFTParamsBase Class
FFTParamsBase Members


FFTParamsBase.ScalingType Property

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsBase..::..ScalingType Property
FFTParamsBase Class See Also Send Feedback
Gets and sets the ScalingType for the FFT calculation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public ScalingType ScalingType { get; set; }
Visual Basic
Public Property ScalingType As ScalingType
    Get
    Set

Property Value

Type: ScalingType

See Also

FFTParamsBase Class
FFTParamsBase Members


FFTParamsBase.ScalingValue Property

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsBase..::..ScalingValue Property
FFTParamsBase Class See Also Send Feedback
Gets and sets the ScalingValue for the FFT calculation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public ScalingValue ScalingValue { get; set; }
Visual Basic
Public Property ScalingValue As ScalingValue
    Get
    Set

Property Value

Type: ScalingValue

See Also

FFTParamsBase Class
FFTParamsBase Members


FFTParamsBase Events

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTParamsBase Events
FFTParamsBase Class See Also Send Feedback

The FFTParamsBase type exposes the following members.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

FFTParamsBase Class


FFTParamsDual Class

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsDual Class
Members See Also Send Feedback
The FFTParamsDual class provides properties that are used to specify parameters for a two-channel FFT operation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public class FFTParamsDual : FFTParamsBase,
    IDisposable
Visual Basic
Public Class FFTParamsDual
    Inherits FFTParamsBase
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
DataTranslation.SignalProcessing..::..FFTParamsBase
DataTranslation.SignalProcessing..::..FFTParamsDual

See Also

FFTParamsDual Members


FFTParamsDual Members

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTParamsDual Members
FFTParamsDual Class Methods Properties Events See Also Send Feedback

The FFTParamsDual type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CrossSpectrumFunction | Gets and sets the CrossSpectrumFunction type that is used when performing a cross spectrum function.
Public property | DbReferenceValue | Gets and sets the reference value that is used when dB scaling is specified. (Inherited from FFTParamsBase.)
Public property | FFTSize | Gets and sets the number of data points to use when generating FFTs. (Inherited from FFTParamsBase.)
Public property | FRFEstimator | Gets and sets the FRFEstimator value that is used when processing an FRF function.
Public property | FRFMode | Gets and sets the FRFMode that is used when processing an FRF function.
Public property | IntegrationTypeReference | Gets and sets the IntegrationType that is applied to the reference channel for a two-channel FFT operation.
Public property | IntegrationTypeResponse | Gets and sets the IntegrationType that is applied to the response channel for a two-channel FFT operation.
Public property | PhaseNoiseThreshold | Gets and sets the phase noise threshold value. (Inherited from FFTParamsBase.)
Public property | ReferenceWindow | Gets and sets the Window parameters to apply to the time-domain data of the reference channel before performing a two-channel FFT operation.
Public property | ResponseWindow | Gets and sets the Window parameters to apply to the time-domain data of the response channel before performing a two-channel FFT operation.
Public property | SamplingFrequency | Gets and sets the sampling frequency per channel for the time-domain source data. (Inherited from FFTParamsBase.)
Public property | ScalingType | Gets and sets the ScalingType for the FFT calculation. (Inherited from FFTParamsBase.)
Public property | ScalingValue | Gets and sets the ScalingValue for the FFT calculation. (Inherited from FFTParamsBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SpectrumFunction | Gets and sets the spectrum function (DualChannelSpectrumFunction) that is used for a two-channel FFT operation.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

FFTParamsDual Class


FFTParamsDual Methods

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTParamsDual Methods
FFTParamsDual Class See Also Send Feedback

The FFTParamsDual type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

FFTParamsDual Class


FFTParamsDual Properties

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTParamsDual Properties
FFTParamsDual Class See Also Send Feedback

The FFTParamsDual type exposes the following members.

Properties

 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CrossSpectrumFunction | Gets and sets the CrossSpectrumFunction type that is used when performing a cross spectrum function.
Public property | DbReferenceValue | Gets and sets the reference value that is used when dB scaling is specified. (Inherited from FFTParamsBase.)
Public property | FFTSize | Gets and sets the number of data points to use when generating FFTs. (Inherited from FFTParamsBase.)
Public property | FRFEstimator | Gets and sets the FRFEstimator value that is used when processing an FRF function.
Public property | FRFMode | Gets and sets the FRFMode that is used when processing an FRF function.
Public property | IntegrationTypeReference | Gets and sets the IntegrationType that is applied to the reference channel for a two-channel FFT operation.
Public property | IntegrationTypeResponse | Gets and sets the IntegrationType that is applied to the response channel for a two-channel FFT operation.
Public property | PhaseNoiseThreshold | Gets and sets the phase noise threshold value. (Inherited from FFTParamsBase.)
Public property | ReferenceWindow | Gets and sets the Window parameters to apply to the time-domain data of the reference channel before performing a two-channel FFT operation.
Public property | ResponseWindow | Gets and sets the Window parameters to apply to the time-domain data of the response channel before performing a two-channel FFT operation.
Public property | SamplingFrequency | Gets and sets the sampling frequency per channel for the time-domain source data. (Inherited from FFTParamsBase.)
Public property | ScalingType | Gets and sets the ScalingType for the FFT calculation. (Inherited from FFTParamsBase.)
Public property | ScalingValue | Gets and sets the ScalingValue for the FFT calculation. (Inherited from FFTParamsBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SpectrumFunction | Gets and sets the spectrum function (DualChannelSpectrumFunction) that is used for a two-channel FFT operation.

See Also

FFTParamsDual Class


FFTParamsDual.CrossSpectrumFunction Property

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsDual..::..CrossSpectrumFunction Property
FFTParamsDual Class See Also Send Feedback
Gets and sets the CrossSpectrumFunction type that is used when performing a cross spectrum function.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public CrossSpectrumFunction CrossSpectrumFunction { get; set; }
Visual Basic
Public Property CrossSpectrumFunction As CrossSpectrumFunction
    Get
    Set

Property Value

Type: CrossSpectrumFunction

See Also

FFTParamsDual Class
FFTParamsDual Members


FFTParamsDual.FRFEstimator Property

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsDual..::..FRFEstimator Property
FFTParamsDual Class See Also Send Feedback
Gets and sets the FRFEstimator value that is used when processing an FRF function.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public FRFEstimator FRFEstimator { get; set; }
Visual Basic
Public Property FRFEstimator As FRFEstimator
    Get
    Set

Property Value

Type: FRFEstimator

See Also

FFTParamsDual Class
FFTParamsDual Members


FFTParamsDual.FRFMode Property

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsDual..::..FRFMode Property
FFTParamsDual Class See Also Send Feedback
Gets and sets the FRFMode that is used when processing an FRF function.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public FRFMode FRFMode { get; set; }
Visual Basic
Public Property FRFMode As FRFMode
    Get
    Set

Property Value

Type: FRFMode

Remarks

Based on the specified mode, the Signal Processing Library for .NET sets the integration type for the response channel, accordingly. If Custom is selected, the IntegrationTypeReference, and IntegrationTypeResponse properties must be set to the desired values.

See Also

FFTParamsDual Class
FFTParamsDual Members


FFTParamsDual.IntegrationTypeReference Property

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsDual..::..IntegrationTypeReference Property
FFTParamsDual Class See Also Send Feedback
Gets and sets the IntegrationType that is applied to the reference channel for a two-channel FFT operation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public IntegrationType IntegrationTypeReference { get; set; }
Visual Basic
Public Property IntegrationTypeReference As IntegrationType
    Get
    Set

Property Value

Type: IntegrationType

See Also

FFTParamsDual Class
FFTParamsDual Members


FFTParamsDual.IntegrationTypeResponse Property

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsDual..::..IntegrationTypeResponse Property
FFTParamsDual Class See Also Send Feedback
Gets and sets the IntegrationType that is applied to the response channel for a two-channel FFT operation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public IntegrationType IntegrationTypeResponse { get; set; }
Visual Basic
Public Property IntegrationTypeResponse As IntegrationType
    Get
    Set

Property Value

Type: IntegrationType

See Also

FFTParamsDual Class
FFTParamsDual Members


FFTParamsDual.ReferenceWindow Property

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsDual..::..ReferenceWindow Property
FFTParamsDual Class See Also Send Feedback
Gets and sets the Window parameters to apply to the time-domain data of the reference channel before performing a two-channel FFT operation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public Window ReferenceWindow { get; }
Visual Basic
Public ReadOnly Property ReferenceWindow As Window
    Get

Property Value

Type: Window

See Also

FFTParamsDual Class
FFTParamsDual Members


FFTParamsDual.ResponseWindow Property

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsDual..::..ResponseWindow Property
FFTParamsDual Class See Also Send Feedback
Gets and sets the Window parameters to apply to the time-domain data of the response channel before performing a two-channel FFT operation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public Window ResponseWindow { get; }
Visual Basic
Public ReadOnly Property ResponseWindow As Window
    Get

Property Value

Type: Window

See Also

FFTParamsDual Class
FFTParamsDual Members


FFTParamsDual.SpectrumFunction Property

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsDual..::..SpectrumFunction Property
FFTParamsDual Class See Also Send Feedback
Gets and sets the spectrum function (DualChannelSpectrumFunction) that is used for a two-channel FFT operation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public DualChannelSpectrumFunction SpectrumFunction { get; set; }
Visual Basic
Public Property SpectrumFunction As DualChannelSpectrumFunction
    Get
    Set

Property Value

Type: DualChannelSpectrumFunction

See Also

FFTParamsDual Class
FFTParamsDual Members


FFTParamsDual Events

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTParamsDual Events
FFTParamsDual Class See Also Send Feedback

The FFTParamsDual type exposes the following members.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

FFTParamsDual Class


FFTParamsSingle Class

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsSingle Class
Members See Also Send Feedback
The FFTParamsSingle class provides properties that are used to specify parameters for a single-channel FFT operation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public class FFTParamsSingle : FFTParamsBase,
    IDisposable
Visual Basic
Public Class FFTParamsSingle
    Inherits FFTParamsBase
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
DataTranslation.SignalProcessing..::..FFTParamsBase
DataTranslation.SignalProcessing..::..FFTParamsSingle

See Also

FFTParamsSingle Members


FFTParamsSingle Members

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTParamsSingle Members
FFTParamsSingle Class Methods Properties Events See Also Send Feedback

The FFTParamsSingle type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DbReferenceValue | Gets and sets the reference value that is used when dB scaling is specified. (Inherited from FFTParamsBase.)
Public property | FFTSize | Gets and sets the number of data points to use when generating FFTs. (Inherited from FFTParamsBase.)
Public property | IntegrationType | Gets and sets the IntegrationType that is used for a single-channel FFT operation.
Public property | PhaseNoiseThreshold | Gets and sets the phase noise threshold value. (Inherited from FFTParamsBase.)
Public property | SamplingFrequency | Gets and sets the sampling frequency per channel for the time-domain source data. (Inherited from FFTParamsBase.)
Public property | ScalingType | Gets and sets the ScalingType for the FFT calculation. (Inherited from FFTParamsBase.)
Public property | ScalingValue | Gets and sets the ScalingValue for the FFT calculation. (Inherited from FFTParamsBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SpectrumFunction | Gets and sets the spectrum function (SingleChannelSpectrumFunction) that is used for a single-channel FFT operation.
Public property | Window | Gets and sets the Window parameters to apply to the time-domain data before performing a single-channel FFT operation.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

FFTParamsSingle Class


FFTParamsSingle Methods

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTParamsSingle Methods
FFTParamsSingle Class See Also Send Feedback

The FFTParamsSingle type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

FFTParamsSingle Class


FFTParamsSingle Properties

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTParamsSingle Properties
FFTParamsSingle Class See Also Send Feedback

The FFTParamsSingle type exposes the following members.

Properties

 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DbReferenceValue | Gets and sets the reference value that is used when dB scaling is specified. (Inherited from FFTParamsBase.)
Public property | FFTSize | Gets and sets the number of data points to use when generating FFTs. (Inherited from FFTParamsBase.)
Public property | IntegrationType | Gets and sets the IntegrationType that is used for a single-channel FFT operation.
Public property | PhaseNoiseThreshold | Gets and sets the phase noise threshold value. (Inherited from FFTParamsBase.)
Public property | SamplingFrequency | Gets and sets the sampling frequency per channel for the time-domain source data. (Inherited from FFTParamsBase.)
Public property | ScalingType | Gets and sets the ScalingType for the FFT calculation. (Inherited from FFTParamsBase.)
Public property | ScalingValue | Gets and sets the ScalingValue for the FFT calculation. (Inherited from FFTParamsBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SpectrumFunction | Gets and sets the spectrum function (SingleChannelSpectrumFunction) that is used for a single-channel FFT operation.
Public property | Window | Gets and sets the Window parameters to apply to the time-domain data before performing a single-channel FFT operation.

See Also

FFTParamsSingle Class


FFTParamsSingle.IntegrationType Property

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsSingle..::..IntegrationType Property
FFTParamsSingle Class See Also Send Feedback
Gets and sets the IntegrationType that is used for a single-channel FFT operation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public IntegrationType IntegrationType { get; set; }
Visual Basic
Public Property IntegrationType As IntegrationType
    Get
    Set

Property Value

Type: IntegrationType

See Also

FFTParamsSingle Class
FFTParamsSingle Members


FFTParamsSingle.SpectrumFunction Property

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsSingle..::..SpectrumFunction Property
FFTParamsSingle Class See Also Send Feedback
Gets and sets the spectrum function (SingleChannelSpectrumFunction) that is used for a single-channel FFT operation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public SingleChannelSpectrumFunction SpectrumFunction { get; set; }
Visual Basic
Public Property SpectrumFunction As SingleChannelSpectrumFunction
    Get
    Set

Property Value

Type: SingleChannelSpectrumFunction

See Also

FFTParamsSingle Class
FFTParamsSingle Members


FFTParamsSingle.Window Property

[image]

Signal Processing Component Library for .NET Documentation
FFTParamsSingle..::..Window Property
FFTParamsSingle Class See Also Send Feedback
Gets and sets the Window parameters to apply to the time-domain data before performing a single-channel FFT operation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public Window Window { get; }
Visual Basic
Public ReadOnly Property Window As Window
    Get

Property Value

Type: Window

See Also

FFTParamsSingle Class
FFTParamsSingle Members


FFTParamsSingle Events

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTParamsSingle Events
FFTParamsSingle Class See Also Send Feedback

The FFTParamsSingle type exposes the following members.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

FFTParamsSingle Class


FFTResultDual Class

[image]

Signal Processing Component Library for .NET Documentation
FFTResultDual Class
Members See Also Send Feedback
The FFTResultDual class contains the result of a two-channel FFT operation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public class FFTResultDual
Visual Basic
Public Class FFTResultDual

Inheritance Hierarchy

System..::..Object
DataTranslation.SignalProcessing..::..FFTResultDual

See Also

FFTResultDual Members


FFTResultDual Members

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTResultDual Members
FFTResultDual Class Methods Properties See Also Send Feedback

The FFTResultDual type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ComplexProcessedResult | Returns the result of a two-channel FFT operation, with integration, spectral density, and scaling parameters applied, as complex processed FFT data.
Public property | Phase | Returns the result of a two-channel FFT operation as phase data.
Public property | RealResult | Returns the result of a two-channel FFT operation, with all the FFT processing parameters applied, as real data.
Public property | ReferenceWindowedData | Returns the result of applying the specified Window to the reference time-domain source data.
Public property | ResponseWindowedData | Returns the result of applying the specified Window to the response time-domain source data.

See Also

FFTResultDual Class


FFTResultDual Methods

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTResultDual Methods
FFTResultDual Class See Also Send Feedback

The FFTResultDual type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FFTResultDual Class


FFTResultDual Properties

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTResultDual Properties
FFTResultDual Class See Also Send Feedback

The FFTResultDual type exposes the following members.

Properties

 | Name | Description
Public property | ComplexProcessedResult | Returns the result of a two-channel FFT operation, with integration, spectral density, and scaling parameters applied, as complex processed FFT data.
Public property | Phase | Returns the result of a two-channel FFT operation as phase data.
Public property | RealResult | Returns the result of a two-channel FFT operation, with all the FFT processing parameters applied, as real data.
Public property | ReferenceWindowedData | Returns the result of applying the specified Window to the reference time-domain source data.
Public property | ResponseWindowedData | Returns the result of applying the specified Window to the response time-domain source data.

See Also

FFTResultDual Class


FFTResultDual.ComplexProcessedResult Property

[image]

Signal Processing Component Library for .NET Documentation
FFTResultDual..::..ComplexProcessedResult Property
FFTResultDual Class See Also Send Feedback
Returns the result of a two-channel FFT operation, with integration, spectral density, and scaling parameters applied, as complex processed FFT data.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double[,] ComplexProcessedResult { get; internal set; }
Visual Basic
Public Property ComplexProcessedResult As Double(,)
    Get
    Friend Set

Property Value

Type: array< Double ,2>[,](,)[,][,]

See Also

FFTResultDual Class
FFTResultDual Members


FFTResultDual.Phase Property

[image]

Signal Processing Component Library for .NET Documentation
FFTResultDual..::..Phase Property
FFTResultDual Class See Also Send Feedback
Returns the result of a two-channel FFT operation as phase data.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double[] Phase { get; internal set; }
Visual Basic
Public Property Phase As Double()
    Get
    Friend Set

Property Value

Type: array< Double >[]()[][]

See Also

FFTResultDual Class
FFTResultDual Members


FFTResultDual.RealResult Property

[image]

Signal Processing Component Library for .NET Documentation
FFTResultDual..::..RealResult Property
FFTResultDual Class See Also Send Feedback
Returns the result of a two-channel FFT operation, with all the FFT processing parameters applied, as real data.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double[] RealResult { get; internal set; }
Visual Basic
Public Property RealResult As Double()
    Get
    Friend Set

Property Value

Type: array< Double >[]()[][]

See Also

FFTResultDual Class
FFTResultDual Members


FFTResultDual.ReferenceWindowedData Property

[image]

Signal Processing Component Library for .NET Documentation
FFTResultDual..::..ReferenceWindowedData Property
FFTResultDual Class See Also Send Feedback
Returns the result of applying the specified Window to the reference time-domain source data.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double[] ReferenceWindowedData { get; internal set; }
Visual Basic
Public Property ReferenceWindowedData As Double()
    Get
    Friend Set

Property Value

Type: array< Double >[]()[][]

See Also

FFTResultDual Class
FFTResultDual Members


FFTResultDual.ResponseWindowedData Property

[image]

Signal Processing Component Library for .NET Documentation
FFTResultDual..::..ResponseWindowedData Property
FFTResultDual Class See Also Send Feedback
Returns the result of applying the specified Window to the response time-domain source data.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double[] ResponseWindowedData { get; internal set; }
Visual Basic
Public Property ResponseWindowedData As Double()
    Get
    Friend Set

Property Value

Type: array< Double >[]()[][]

See Also

FFTResultDual Class
FFTResultDual Members


FFTResultSingle Class

[image]

Signal Processing Component Library for .NET Documentation
FFTResultSingle Class
Members See Also Send Feedback
The FFTResultSingle class contains the result of a single-channel FFT operation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public class FFTResultSingle
Visual Basic
Public Class FFTResultSingle

Inheritance Hierarchy

System..::..Object
DataTranslation.SignalProcessing..::..FFTResultSingle

See Also

FFTResultSingle Members


FFTResultSingle Members

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTResultSingle Members
FFTResultSingle Class Methods Properties See Also Send Feedback

The FFTResultSingle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ComplexProcessedResult | Returns the result of a single-channel FFT operation, with integration, spectral density, and scaling parameters applied, as complex processed FFT data.
Public property | ComplexUnprocessedResult | Returns the result of a single-channel FFT operation as complex, normalized, unprocessed FFT data.
Public property | Phase | Returns the result of a single-channel FFT operation as phase data.
Public property | RealResult | Returns the result of a single-channel FFT operation, with all the FFT processing parameters applied, as real data.
Public property | WindowedData | Returns the result of applying the specified Window to the time-domain source data.

See Also

FFTResultSingle Class


FFTResultSingle Methods

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTResultSingle Methods
FFTResultSingle Class See Also Send Feedback

The FFTResultSingle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FFTResultSingle Class


FFTResultSingle Properties

[image] [image]

Signal Processing Component Library for .NET Documentation
FFTResultSingle Properties
FFTResultSingle Class See Also Send Feedback

The FFTResultSingle type exposes the following members.

Properties

 | Name | Description
Public property | ComplexProcessedResult | Returns the result of a single-channel FFT operation, with integration, spectral density, and scaling parameters applied, as complex processed FFT data.
Public property | ComplexUnprocessedResult | Returns the result of a single-channel FFT operation as complex, normalized, unprocessed FFT data.
Public property | Phase | Returns the result of a single-channel FFT operation as phase data.
Public property | RealResult | Returns the result of a single-channel FFT operation, with all the FFT processing parameters applied, as real data.
Public property | WindowedData | Returns the result of applying the specified Window to the time-domain source data.

See Also

FFTResultSingle Class


FFTResultSingle.ComplexProcessedResult Property

[image]

Signal Processing Component Library for .NET Documentation
FFTResultSingle..::..ComplexProcessedResult Property
FFTResultSingle Class See Also Send Feedback
Returns the result of a single-channel FFT operation, with integration, spectral density, and scaling parameters applied, as complex processed FFT data.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double[,] ComplexProcessedResult { get; internal set; }
Visual Basic
Public Property ComplexProcessedResult As Double(,)
    Get
    Friend Set

Property Value

Type: array< Double ,2>[,](,)[,][,]

See Also

FFTResultSingle Class
FFTResultSingle Members


FFTResultSingle.ComplexUnprocessedResult Property

[image]

Signal Processing Component Library for .NET Documentation
FFTResultSingle..::..ComplexUnprocessedResult Property
FFTResultSingle Class See Also Send Feedback
Returns the result of a single-channel FFT operation as complex, normalized, unprocessed FFT data.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double[,] ComplexUnprocessedResult { get; internal set; }
Visual Basic
Public Property ComplexUnprocessedResult As Double(,)
    Get
    Friend Set

Property Value

Type: array< Double ,2>[,](,)[,][,]

See Also

FFTResultSingle Class
FFTResultSingle Members


FFTResultSingle.Phase Property

[image]

Signal Processing Component Library for .NET Documentation
FFTResultSingle..::..Phase Property
FFTResultSingle Class See Also Send Feedback
Returns the result of a single-channel FFT operation as phase data.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double[] Phase { get; internal set; }
Visual Basic
Public Property Phase As Double()
    Get
    Friend Set

Property Value

Type: array< Double >[]()[][]

See Also

FFTResultSingle Class
FFTResultSingle Members


FFTResultSingle.RealResult Property

[image]

Signal Processing Component Library for .NET Documentation
FFTResultSingle..::..RealResult Property
FFTResultSingle Class See Also Send Feedback
Returns the result of a single-channel FFT operation, with all the FFT processing parameters applied, as real data.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double[] RealResult { get; internal set; }
Visual Basic
Public Property RealResult As Double()
    Get
    Friend Set

Property Value

Type: array< Double >[]()[][]

See Also

FFTResultSingle Class
FFTResultSingle Members


FFTResultSingle.WindowedData Property

[image]

Signal Processing Component Library for .NET Documentation
FFTResultSingle..::..WindowedData Property
FFTResultSingle Class See Also Send Feedback
Returns the result of applying the specified Window to the time-domain source data.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double[] WindowedData { get; internal set; }
Visual Basic
Public Property WindowedData As Double()
    Get
    Friend Set

Property Value

Type: array< Double >[]()[][]

See Also

FFTResultSingle Class
FFTResultSingle Members


FRFEstimator Enumeration

[image]

Signal Processing Component Library for .NET Documentation
FRFEstimator Enumeration
See Also Send Feedback
FRF estimator type for the FRF function. This enumeration is used by the FRFEstimator property.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public enum FRFEstimator
Visual Basic
Public Enumeration FRFEstimator

Members

Member name | Value | Description
H1 | 0 | Reduces noise on the response channel. It is calculated as follows: H1 = Sxf/Sff where, Sxf represents the average cross power spectrum between the response and the reference signals. Sff represents the average auto power spectrum of the reference signal.
H2 | 1 | Reduces noise on the reference channel. It is calculated as follows: H2 = Sxx/Sfx where, Sxx represents the average auto spectrum of the response signal. Sfx represents the average cross power spectrum between the response and the reference signals.
H3 | 2 | Reduces noise on both the reference and response channels. H3 is computed as follows: H3 = (H1 + H2)/2

See Also

DataTranslation.SignalProcessing Namespace

Send comments on this topic to info@datx.com

Copyright © 2013 by Data Translation, Inc.


FRFMode Enumeration

[image]

Signal Processing Component Library for .NET Documentation
FRFMode Enumeration
See Also Send Feedback
FRF mode for the FRF function. Based on the specified mode, the Signal Processing Library for .NET sets the integration type for the response channel accordingly. This enumeration is used by the FRFMode property.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public enum FRFMode
Visual Basic
Public Enumeration FRFMode

Members

Member name | Value | Description
Inertance | 0 | Acceleration of Response Channel/Force of Reference Channel
Mobility | 1 | Velocity of Response Channel/Force of Reference Channel
Compliance | 2 | Displacement of Response Channel/Force of Reference Channel
ApparentMass | 3 | Force of the Reference Channel/Acceleration of Response Channel
Impedance | 4 | Force of Reference Channel/Velocity of the Response Channel
DynamicStiffness | 5 | Force of Reference Channel/Displacement of Response Channel
Custom | 6 | When you choose this option, you can specify an IntegrationType for the response channel and an IntegrationType for the reference channel, if desired. The following selections are available: None (No integration; acceleration data is represented as acceleration), Single (Data is integrated once; acceleration data is represented as velocity), Double (Data is integrated twice; acceleration data is represented as displacement).

See Also

DataTranslation.SignalProcessing Namespace

Send comments on this topic to info@datx.com

Copyright © 2013 by Data Translation, Inc.


IntegrationType Enumeration

[image]

Signal Processing Component Library for .NET Documentation
IntegrationType Enumeration
See Also Send Feedback
Integration type for the FFT operation. This enumeration is used by the IntegrationType, IntegrationTypeReference, and IntegrationTypeResponse properties.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public enum IntegrationType
Visual Basic
Public Enumeration IntegrationType

Members

Member name | Value | Description
None | 0 | No integration; acceleration data is represented as acceleration.
Single | 1 | Data is integrated once; acceleration data is represented as velocity.
Double | 2 | Data is integrated twice; acceleration data is represented as displacement.

See Also

DataTranslation.SignalProcessing Namespace

Send comments on this topic to info@datx.com

Copyright © 2013 by Data Translation, Inc.


ScalingType Enumeration

[image]

Signal Processing Component Library for .NET Documentation
ScalingType Enumeration
See Also Send Feedback
Scaling type for the resulting data. This enumeration is used by the ScalingType property.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public enum ScalingType
Visual Basic
Public Enumeration ScalingType

Members

Member name | Value | Description
Linear | 0 | The resulting data uses linear scaling.
db | 1 | The resulting data uses logarithmic scaling.

See Also

DataTranslation.SignalProcessing Namespace

Send comments on this topic to info@datx.com

Copyright © 2013 by Data Translation, Inc.


ScalingValue Enumeration

[image]

Signal Processing Component Library for .NET Documentation
ScalingValue Enumeration
See Also Send Feedback
Scaling value of the resulting data relative to the input signal. This enumeration is used by the ScalingValue property.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public enum ScalingValue
Visual Basic
Public Enumeration ScalingValue

Members

Member name | Value | Description
Peak | 0 | The absolute value of the data from zero to the peak.
PeakPeak | 1 | The absolute value of the data from the negative peak to the positive peak.
RMS | 2 | Root Mean Square. The square root of the average of the square of the value of the function taken throughout one period.

See Also

DataTranslation.SignalProcessing Namespace

Send comments on this topic to info@datx.com

Copyright © 2013 by Data Translation, Inc.


SignalMetrics Class

[image]

Signal Processing Component Library for .NET Documentation
SignalMetrics Class
Members See Also Send Feedback
The SignalMetrics class provides the properties and methods for calculating metrics (IBF, THD, SFDR, SINAD, ENOB, and SNR) on the time-domain data.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public class SignalMetrics : Component
Visual Basic
Public Class SignalMetrics
    Inherits Component

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
DataTranslation.SignalProcessing..::..SignalMetrics

See Also

SignalMetrics Members


SignalMetrics Members

[image] [image]

Signal Processing Component Library for .NET Documentation
SignalMetrics Members
SignalMetrics Class Constructors Methods Properties Events See Also Send Feedback

The SignalMetrics type exposes the following members.

Constructors

 | Name | Description
Public method | SignalMetrics()()()() | Initializes a new instance of the SignalMetrics class.
Public method | SignalMetrics(IContainer) | Initializes a new instance of the SignalMetrics class.

Methods

 | Name | Description
Public method | ComputeMetrics | Computes the signal metrics based on the specified parameters and returns the result in a variable of type SignalMetricsResult.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | FFTSize | Gets and sets the number of data points to use when generating FFTs.
Public property | FullScaleRange | Gets and sets the full-scale range (max positive value) of the device from which the data was acquired.
Public property | RequiredNumberOfTHDHarmonics | Gets and sets the minimum number of harmonics required for the Total Harmonic Distortion (THD) calculation.
Public property | SamplingFrequency | Gets and sets the sampling frequency of the time-domain source data.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

SignalMetrics Class


SignalMetrics Constructor

[image] [image]

Signal Processing Component Library for .NET Documentation
SignalMetrics Constructor
SignalMetrics Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SignalMetrics()()()() | Initializes a new instance of the SignalMetrics class.
Public method | SignalMetrics(IContainer) | Initializes a new instance of the SignalMetrics class.

See Also

SignalMetrics Class
SignalMetrics Members


SignalMetrics Constructor

[image]

Signal Processing Component Library for .NET Documentation
SignalMetrics Constructor
SignalMetrics Class See Also Send Feedback
Initializes a new instance of the SignalMetrics class.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public SignalMetrics()
Visual Basic
Public Sub New

Remarks

For client run-time licensing to work correctly this constructor should not be called directly. The component must be dragged to the form from the Visual Studio Toolbox.

See Also

SignalMetrics Class
SignalMetrics Members
SignalMetrics Overload


SignalMetrics Constructor (IContainer)

[image]

Signal Processing Component Library for .NET Documentation
SignalMetrics Constructor (IContainer)
SignalMetrics Class See Also Send Feedback
Initializes a new instance of the SignalMetrics class.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public SignalMetrics(
    IContainer container
)
Visual Basic
Public Sub New (
    container As IContainer
)

Parameters

container
Type: System.ComponentModel..::..IContainer
The System.ComponentModel.IContainer interface.

Remarks

For client run-time licensing to work correctly this constructor should not be called directly. The component must be dragged to the form from the Visual Studio Toolbox.

See Also

SignalMetrics Class
SignalMetrics Members
SignalMetrics Overload


SignalMetrics Methods

[image] [image]

Signal Processing Component Library for .NET Documentation
SignalMetrics Methods
SignalMetrics Class See Also Send Feedback

The SignalMetrics type exposes the following members.

Methods

 | Name | Description
Public method | ComputeMetrics | Computes the signal metrics based on the specified parameters and returns the result in a variable of type SignalMetricsResult.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

SignalMetrics Class


SignalMetrics.ComputeMetrics Method

[image]

Signal Processing Component Library for .NET Documentation
SignalMetrics..::..ComputeMetrics Method
SignalMetrics Class See Also Send Feedback
Computes the signal metrics based on the specified parameters and returns the result in a variable of type SignalMetricsResult.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public SignalMetricsResult ComputeMetrics(
    double[] data
)
Visual Basic
Public Function ComputeMetrics (
    data As Double()
) As SignalMetricsResult

Parameters

data
Type: array< System..::..Double >[]()[][]
The time-domain input data.

Return Value

Type: SignalMetricsResult
The calculated metrics (IBF, THD, SFDR, SINAD, ENOB, and SNR) for the data.

See Also

SignalMetrics Class
SignalMetrics Members


SignalMetrics Properties

[image] [image]

Signal Processing Component Library for .NET Documentation
SignalMetrics Properties
SignalMetrics Class See Also Send Feedback

The SignalMetrics type exposes the following members.

Properties

 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | FFTSize | Gets and sets the number of data points to use when generating FFTs.
Public property | FullScaleRange | Gets and sets the full-scale range (max positive value) of the device from which the data was acquired.
Public property | RequiredNumberOfTHDHarmonics | Gets and sets the minimum number of harmonics required for the Total Harmonic Distortion (THD) calculation.
Public property | SamplingFrequency | Gets and sets the sampling frequency of the time-domain source data.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

SignalMetrics Class


SignalMetrics.FFTSize Property

[image]

Signal Processing Component Library for .NET Documentation
SignalMetrics..::..FFTSize Property
SignalMetrics Class See Also Send Feedback
Gets and sets the number of data points to use when generating FFTs.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public int FFTSize { get; set; }
Visual Basic
Public Property FFTSize As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

The value of FFTSize must be a power of 2. The resultant number of spectral lines is half the value of FFTSize.

See Also

SignalMetrics Class
SignalMetrics Members


SignalMetrics.FullScaleRange Property

[image]

Signal Processing Component Library for .NET Documentation
SignalMetrics..::..FullScaleRange Property
SignalMetrics Class See Also Send Feedback
Gets and sets the full-scale range (max positive value) of the device from which the data was acquired.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double FullScaleRange { get; set; }
Visual Basic
Public Property FullScaleRange As Double
    Get
    Set

Property Value

Type: Double

See Also

SignalMetrics Class
SignalMetrics Members


SignalMetrics.RequiredNumberOfTHDHarmonics Property

[image]

Signal Processing Component Library for .NET Documentation
SignalMetrics..::..RequiredNumberOfTHDHarmonics Property
SignalMetrics Class See Also Send Feedback
Gets and sets the minimum number of harmonics required for the Total Harmonic Distortion (THD) calculation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public int RequiredNumberOfTHDHarmonics { get; set; }
Visual Basic
Public Property RequiredNumberOfTHDHarmonics As Integer
    Get
    Set

Property Value

Type: Int32

See Also

SignalMetrics Class
SignalMetrics Members


SignalMetrics.SamplingFrequency Property

[image]

Signal Processing Component Library for .NET Documentation
SignalMetrics..::..SamplingFrequency Property
SignalMetrics Class See Also Send Feedback
Gets and sets the sampling frequency of the time-domain source data.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double SamplingFrequency { get; set; }
Visual Basic
Public Property SamplingFrequency As Double
    Get
    Set

Property Value

Type: Double

See Also

SignalMetrics Class
SignalMetrics Members


SignalMetrics Events

[image] [image]

Signal Processing Component Library for .NET Documentation
SignalMetrics Events
SignalMetrics Class See Also Send Feedback

The SignalMetrics type exposes the following members.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

SignalMetrics Class


SignalMetricsResult Class

[image]

Signal Processing Component Library for .NET Documentation
SignalMetricsResult Class
Members See Also Send Feedback
The SignalMetricsResult class contains the metrics (IBF, THD, SFDR, SINAD, ENOB, and SNR) that were calculated on the data using the SignalMetrics class.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public class SignalMetricsResult
Visual Basic
Public Class SignalMetricsResult

Remarks

Using these metrics, you can quantify the analog characteristics of the data that was acquired through the A/D converter on the device.

Inheritance Hierarchy

System..::..Object
DataTranslation.SignalProcessing..::..SignalMetricsResult

See Also

SignalMetricsResult Members


SignalMetricsResult Members

[image] [image]

Signal Processing Component Library for .NET Documentation
SignalMetricsResult Members
SignalMetricsResult Class Methods Fields Properties See Also Send Feedback

The SignalMetricsResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | THD | Returns the THD structure, which contains the resuluts of the Total Harmonic Distortion calculation.

Properties

 | Name | Description
Public property | ENOB | Returns the Effective Number of Bits value.
Public property | FFTResultData | Returns the FFT magnitude data for the FFT AutoSpectrum calculation that is done as a precursor to the signal metrics calculations.
Public property | FFTResultSpectrumFrequencies | Returns the per bin spectrum frequencies for the FFT AutoSpectrum calculation that is done as a precursor to the signal metrics calculations.
Public property | IBF | Returns the Input Below Full-scale value.
Public property | NotEnoughHarmonicsForTHD | Returns True if the signal contains less than the required number of harmonics for THD calculations, or False if the signal contains the required number of harmonics for THD calculations.
Public property | SFDR | Returns the Spurious Free Dynamic Range value.
Public property | SINAD | Returns the Signal-to-Noise and Distortion value.
Public property | SNR | Returns the Signal-to-Noise Ratio value.

See Also

SignalMetricsResult Class


SignalMetricsResult Fields

[image] [image]

Signal Processing Component Library for .NET Documentation
SignalMetricsResult Fields
SignalMetricsResult Class See Also Send Feedback

The SignalMetricsResult type exposes the following members.

Fields

 | Name | Description
Public field | THD | Returns the THD structure, which contains the resuluts of the Total Harmonic Distortion calculation.

See Also

SignalMetricsResult Class


SignalMetricsResult.THD Field

[image]

Signal Processing Component Library for .NET Documentation
SignalMetricsResult..::..THD Field
SignalMetricsResult Class See Also Send Feedback
Returns the THD structure, which contains the resuluts of the Total Harmonic Distortion calculation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public THD THD
Visual Basic
Public THD As THD

Field Value

Type: THD

See Also

SignalMetricsResult Class
SignalMetricsResult Members


SignalMetricsResult Methods

[image] [image]

Signal Processing Component Library for .NET Documentation
SignalMetricsResult Methods
SignalMetricsResult Class See Also Send Feedback

The SignalMetricsResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SignalMetricsResult Class


SignalMetricsResult Properties

[image] [image]

Signal Processing Component Library for .NET Documentation
SignalMetricsResult Properties
SignalMetricsResult Class See Also Send Feedback

The SignalMetricsResult type exposes the following members.

Properties

 | Name | Description
Public property | ENOB | Returns the Effective Number of Bits value.
Public property | FFTResultData | Returns the FFT magnitude data for the FFT AutoSpectrum calculation that is done as a precursor to the signal metrics calculations.
Public property | FFTResultSpectrumFrequencies | Returns the per bin spectrum frequencies for the FFT AutoSpectrum calculation that is done as a precursor to the signal metrics calculations.
Public property | IBF | Returns the Input Below Full-scale value.
Public property | NotEnoughHarmonicsForTHD | Returns True if the signal contains less than the required number of harmonics for THD calculations, or False if the signal contains the required number of harmonics for THD calculations.
Public property | SFDR | Returns the Spurious Free Dynamic Range value.
Public property | SINAD | Returns the Signal-to-Noise and Distortion value.
Public property | SNR | Returns the Signal-to-Noise Ratio value.

See Also

SignalMetricsResult Class


SignalMetricsResult.ENOB Property

[image]

Signal Processing Component Library for .NET Documentation
SignalMetricsResult..::..ENOB Property
SignalMetricsResult Class See Also Send Feedback
Returns the Effective Number of Bits value.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double ENOB { get; internal set; }
Visual Basic
Public Property ENOB As Double
    Get
    Friend Set

Property Value

Type: Double

Remarks

The Effective Number of Bits (ENOB), returned in bits, represents the quality of a digitized signal. The input signal is typically sinusoidal and should be near full-scale to properly characterize the A/D converter and/or system. ENOB is computed using the following equation: ENOB = (SINAD – 1.76 – IBF)/6.02

See Also

SignalMetricsResult Class
SignalMetricsResult Members


SignalMetricsResult.FFTResultData Property

[image]

Signal Processing Component Library for .NET Documentation
SignalMetricsResult..::..FFTResultData Property
SignalMetricsResult Class See Also Send Feedback
Returns the FFT magnitude data for the FFT AutoSpectrum calculation that is done as a precursor to the signal metrics calculations.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double[] FFTResultData { get; internal set; }
Visual Basic
Public Property FFTResultData As Double()
    Get
    Friend Set

Property Value

Type: array< Double >[]()[][]

See Also

SignalMetricsResult Class
SignalMetricsResult Members


SignalMetricsResult.FFTResultSpectrumFrequencies Property

[image]

Signal Processing Component Library for .NET Documentation
SignalMetricsResult..::..FFTResultSpectrumFrequencies Property
SignalMetricsResult Class See Also Send Feedback
Returns the per bin spectrum frequencies for the FFT AutoSpectrum calculation that is done as a precursor to the signal metrics calculations.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double[] FFTResultSpectrumFrequencies { get; internal set; }
Visual Basic
Public Property FFTResultSpectrumFrequencies As Double()
    Get
    Friend Set

Property Value

Type: array< Double >[]()[][]

See Also

SignalMetricsResult Class
SignalMetricsResult Members


SignalMetricsResult.IBF Property

[image]

Signal Processing Component Library for .NET Documentation
SignalMetricsResult..::..IBF Property
SignalMetricsResult Class See Also Send Feedback
Returns the Input Below Full-scale value.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double IBF { get; internal set; }
Visual Basic
Public Property IBF As Double
    Get
    Friend Set

Property Value

Type: Double

Remarks

The Input Below Full-scale (IBF), returned in dB, represents the level of the main signal component relative to the full-scale voltage.

See Also

SignalMetricsResult Class
SignalMetricsResult Members


SignalMetricsResult.NotEnoughHarmonicsForTHD Property

[image]

Signal Processing Component Library for .NET Documentation
SignalMetricsResult..::..NotEnoughHarmonicsForTHD Property
SignalMetricsResult Class See Also Send Feedback
Returns True if the signal contains less than the required number of harmonics for THD calculations, or False if the signal contains the required number of harmonics for THD calculations.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public bool NotEnoughHarmonicsForTHD { get; internal set; }
Visual Basic
Public Property NotEnoughHarmonicsForTHD As Boolean
    Get
    Friend Set

Property Value

Type: Boolean

Remarks

See RequiredNumberOfTHDHarmonics.

See Also

SignalMetricsResult Class
SignalMetricsResult Members


SignalMetricsResult.SFDR Property

[image]

Signal Processing Component Library for .NET Documentation
SignalMetricsResult..::..SFDR Property
SignalMetricsResult Class See Also Send Feedback
Returns the Spurious Free Dynamic Range value.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double SFDR { get; internal set; }
Visual Basic
Public Property SFDR As Double
    Get
    Friend Set

Property Value

Type: Double

Remarks

Spurious Free Dynamic Range (SFDR), returned in dB, represents the level of the full-scale range to the greatest noise or distortion component.

See Also

SignalMetricsResult Class
SignalMetricsResult Members


SignalMetricsResult.SINAD Property

[image]

Signal Processing Component Library for .NET Documentation
SignalMetricsResult..::..SINAD Property
SignalMetricsResult Class See Also Send Feedback
Returns the Signal-to-Noise and Distortion value.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double SINAD { get; internal set; }
Visual Basic
Public Property SINAD As Double
    Get
    Friend Set

Property Value

Type: Double

Remarks

Signal-to-Noise and Distortion (SINAD), returned in dB, represents the level of the main signal component relative to the total noise, VRMS, including harmonics.

See Also

SignalMetricsResult Class
SignalMetricsResult Members


SignalMetricsResult.SNR Property

[image]

Signal Processing Component Library for .NET Documentation
SignalMetricsResult..::..SNR Property
SignalMetricsResult Class See Also Send Feedback
Returns the Signal-to-Noise Ratio value.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double SNR { get; internal set; }
Visual Basic
Public Property SNR As Double
    Get
    Friend Set

Property Value

Type: Double

Remarks

The Signal-to-Noise Ratio (SNR), returned in dB, represents the level of the main signal component relative to the total noise, VRMS.

See Also

SignalMetricsResult Class
SignalMetricsResult Members


SignalProcessingException Class

[image]

Signal Processing Component Library for .NET Documentation
SignalProcessingException Class
Members See Also Send Feedback
The SignalProcessingException class provides properties, fields, and methods that are used to handle exceptions when calculating signal metrics.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public class SignalProcessingException : Exception
Visual Basic
Public Class SignalProcessingException
    Inherits Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
DataTranslation.SignalProcessing..::..SignalProcessingException

See Also

SignalProcessingException Members


SignalProcessingException Members

[image] [image]

Signal Processing Component Library for .NET Documentation
SignalProcessingException Members
SignalProcessingException Class Constructors Methods Fields Properties See Also Send Feedback

The SignalProcessingException type exposes the following members.

Constructors

 | Name | Description
Public method | SignalProcessingException | Initializes a new instance of the SignalProcessingException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | FundamentalBinOutOfRange | The bin with the fundamental frequency is either too close to 0 Hz or too close to the maximum frequency. This exception can be thrown by the ComputeMetrics(array<Double>[]()[][]) method.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SignalProcessingException Class


SignalProcessingException Constructor

[image]

Signal Processing Component Library for .NET Documentation
SignalProcessingException Constructor
SignalProcessingException Class See Also Send Feedback
Initializes a new instance of the SignalProcessingException class

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public SignalProcessingException(
    string Message
)
Visual Basic
Public Sub New (
    Message As String
)

Parameters

Message
Type: System..::..String

[Missing <param name="Message"/> documentation for "M:DataTranslation.SignalProcessing.SignalProcessingException.#ctor(System.String)"]

See Also

SignalProcessingException Class
SignalProcessingException Members


SignalProcessingException Fields

[image] [image]

Signal Processing Component Library for .NET Documentation
SignalProcessingException Fields
SignalProcessingException Class See Also Send Feedback

The SignalProcessingException type exposes the following members.

Fields

 | Name | Description
Public field | FundamentalBinOutOfRange | The bin with the fundamental frequency is either too close to 0 Hz or too close to the maximum frequency. This exception can be thrown by the ComputeMetrics(array<Double>[]()[][]) method.

See Also

SignalProcessingException Class


SignalProcessingException.FundamentalBinOutOfRange Field

[image]

Signal Processing Component Library for .NET Documentation
SignalProcessingException..::..FundamentalBinOutOfRange Field
SignalProcessingException Class See Also Send Feedback
The bin with the fundamental frequency is either too close to 0 Hz or too close to the maximum frequency. This exception can be thrown by the ComputeMetrics(array<Double>[]()[][]) method.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public bool FundamentalBinOutOfRange
Visual Basic
Public FundamentalBinOutOfRange As Boolean

Field Value

Type: Boolean

See Also

SignalProcessingException Class
SignalProcessingException Members


SignalProcessingException Methods

[image] [image]

Signal Processing Component Library for .NET Documentation
SignalProcessingException Methods
SignalProcessingException Class See Also Send Feedback

The SignalProcessingException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

SignalProcessingException Class


SignalProcessingException Properties

[image] [image]

Signal Processing Component Library for .NET Documentation
SignalProcessingException Properties
SignalProcessingException Class See Also Send Feedback

The SignalProcessingException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SignalProcessingException Class


SingleChannelFFT Class

[image]

Signal Processing Component Library for .NET Documentation
SingleChannelFFT Class
Members See Also Send Feedback
The SingleChannelFFT class provides the properties and methods for performing a single-channel FFT operation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public class SingleChannelFFT : FFTBase
Visual Basic
Public Class SingleChannelFFT
    Inherits FFTBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
DataTranslation.SignalProcessing..::..FFTBase
DataTranslation.SignalProcessing..::..SingleChannelFFT

See Also

SingleChannelFFT Members


SingleChannelFFT Members

[image] [image]

Signal Processing Component Library for .NET Documentation
SingleChannelFFT Members
SingleChannelFFT Class Constructors Methods Properties Events See Also Send Feedback

The SingleChannelFFT type exposes the following members.

Constructors

 | Name | Description
Public method | SingleChannelFFT()()()() | Initializes a new instance of the SingleChannelFFT class.
Public method | SingleChannelFFT(IContainer) | Initializes a new instance of the SingleChannelFFT class.

Methods

 | Name | Description
Public method | ComputeFFT | Computes a single-channel FFT based on the specified parameters and returns the result as an array of real values.
Public method | ComputeFFTDetailed | Computes a single-channel FFT based on the specified parameters and returns the result and intermediate data in a variable of type FFTResultSingle.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetSpectrumFrequencyIndex | Returns the bin index of a spectrum frequency. (Inherited from FFTBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | FFTParameters | Returns the parameters that are used in a single-channel FFT calculation.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SpectrumFrequencies | Returns the current bin frequencies for the spectrum. (Inherited from FFTBase.)

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

SingleChannelFFT Class


SingleChannelFFT Constructor

[image] [image]

Signal Processing Component Library for .NET Documentation
SingleChannelFFT Constructor
SingleChannelFFT Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SingleChannelFFT()()()() | Initializes a new instance of the SingleChannelFFT class.
Public method | SingleChannelFFT(IContainer) | Initializes a new instance of the SingleChannelFFT class.

See Also

SingleChannelFFT Class
SingleChannelFFT Members


SingleChannelFFT Constructor

[image]

Signal Processing Component Library for .NET Documentation
SingleChannelFFT Constructor
SingleChannelFFT Class See Also Send Feedback
Initializes a new instance of the SingleChannelFFT class.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public SingleChannelFFT()
Visual Basic
Public Sub New

Remarks

For client run-time licensing to work correctly this constructor should not be called directly. The component must be dragged to the form from the Visual Studio Toolbox.

See Also

SingleChannelFFT Class
SingleChannelFFT Members
SingleChannelFFT Overload


SingleChannelFFT Constructor (IContainer)

[image]

Signal Processing Component Library for .NET Documentation
SingleChannelFFT Constructor (IContainer)
SingleChannelFFT Class See Also Send Feedback
Initializes a new instance of the SingleChannelFFT class.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public SingleChannelFFT(
    IContainer container
)
Visual Basic
Public Sub New (
    container As IContainer
)

Parameters

container
Type: System.ComponentModel..::..IContainer
The System.ComponentModel.IContainer interface.

Remarks

For client run-time licensing to work correctly this constructor should not be called directly. The component must be dragged to the form from the Visual Studio Toolbox.

See Also

SingleChannelFFT Class
SingleChannelFFT Members
SingleChannelFFT Overload


SingleChannelFFT Methods

[image] [image]

Signal Processing Component Library for .NET Documentation
SingleChannelFFT Methods
SingleChannelFFT Class See Also Send Feedback

The SingleChannelFFT type exposes the following members.

Methods

 | Name | Description
Public method | ComputeFFT | Computes a single-channel FFT based on the specified parameters and returns the result as an array of real values.
Public method | ComputeFFTDetailed | Computes a single-channel FFT based on the specified parameters and returns the result and intermediate data in a variable of type FFTResultSingle.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetSpectrumFrequencyIndex | Returns the bin index of a spectrum frequency. (Inherited from FFTBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

SingleChannelFFT Class


SingleChannelFFT.ComputeFFT Method

[image]

Signal Processing Component Library for .NET Documentation
SingleChannelFFT..::..ComputeFFT Method
SingleChannelFFT Class See Also Send Feedback
Computes a single-channel FFT based on the specified parameters and returns the result as an array of real values.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double[] ComputeFFT(
    double[] data
)
Visual Basic
Public Function ComputeFFT (
    data As Double()
) As Double()

Parameters

data
Type: array< System..::..Double >[]()[][]
The time-domain input data.

Return Value

Type: array< Double >[]()[][]
The result of the single-channel FFT operation as a real value.

See Also

SingleChannelFFT Class
SingleChannelFFT Members


SingleChannelFFT.ComputeFFTDetailed Method

[image]

Signal Processing Component Library for .NET Documentation
SingleChannelFFT..::..ComputeFFTDetailed Method
SingleChannelFFT Class See Also Send Feedback
Computes a single-channel FFT based on the specified parameters and returns the result and intermediate data in a variable of type FFTResultSingle.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public FFTResultSingle ComputeFFTDetailed(
    double[] data
)
Visual Basic
Public Function ComputeFFTDetailed (
    data As Double()
) As FFTResultSingle

Parameters

data
Type: array< System..::..Double >[]()[][]
The time-domain input data.

Return Value

Type: FFTResultSingle
The result of the single-channel FFT operation.

See Also

SingleChannelFFT Class
SingleChannelFFT Members


SingleChannelFFT Properties

[image] [image]

Signal Processing Component Library for .NET Documentation
SingleChannelFFT Properties
SingleChannelFFT Class See Also Send Feedback

The SingleChannelFFT type exposes the following members.

Properties

 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | FFTParameters | Returns the parameters that are used in a single-channel FFT calculation.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SpectrumFrequencies | Returns the current bin frequencies for the spectrum. (Inherited from FFTBase.)

See Also

SingleChannelFFT Class


SingleChannelFFT.FFTParameters Property

[image]

Signal Processing Component Library for .NET Documentation
SingleChannelFFT..::..FFTParameters Property
SingleChannelFFT Class See Also Send Feedback
Returns the parameters that are used in a single-channel FFT calculation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public FFTParamsSingle FFTParameters { get; }
Visual Basic
Public ReadOnly Property FFTParameters As FFTParamsSingle
    Get

Property Value

Type: FFTParamsSingle

See Also

SingleChannelFFT Class
SingleChannelFFT Members


SingleChannelFFT Events

[image] [image]

Signal Processing Component Library for .NET Documentation
SingleChannelFFT Events
SingleChannelFFT Class See Also Send Feedback

The SingleChannelFFT type exposes the following members.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

SingleChannelFFT Class


SingleChannelSpectrumFunction Enumeration

[image]

Signal Processing Component Library for .NET Documentation
SingleChannelSpectrumFunction Enumeration
See Also Send Feedback
Spectrum function to perform for a single-channel FFT operation. This enumeration is used by the SpectrumFunction property.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public enum SingleChannelSpectrumFunction
Visual Basic
Public Enumeration SingleChannelSpectrumFunction

Members

Member name | Value | Description
Spectrum | 0 | Calculates the magnitude of a periodic frequency component at a discrete frequency. It is computed as the square root of the average auto spectrum. When using an accelerometer, for example, the units for Spectrum are represented as g. Typically, Spectrum is best for narrowband, deterministic signals.
AutoSpectrum | 1 | Calculates the power of a periodic frequency component at a discrete frequency. When using an accelerometer, for example, the units for AutoSpectrum are represented as g^2. Typically, AutoSpectrum is best for narrowband, deterministic signals.
PSD | 2 | (Power Spectral Density) calculates the power of random vibration intensity as “mean-square acceleration per frequency unit.” The spectrum is computed by squaring the magnitude of each frequency component in the FFT, and dividing this number by the change in frequency multiplied by the equivalent noise bandwidth of the windowing function. When using an accelerometer, for example, the units for PSD are represented as g^2/Hz. Typically, PSD is best for wideband, continuous signals.

See Also

DataTranslation.SignalProcessing Namespace

Send comments on this topic to info@datx.com

Copyright © 2013 by Data Translation, Inc.


THD Structure

[image]

Signal Processing Component Library for .NET Documentation
THD Structure
Members See Also Send Feedback
Structure that contains the Total Harmonic Distortion results.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public struct THD
Visual Basic
Public Structure THD

See Also

THD Members


THD Members

[image] [image]

Signal Processing Component Library for .NET Documentation
THD Members
THD Structure Methods Fields See Also Send Feedback

The THD type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | dB | Total Harmonic Distortion (THD), returned in dB, represents the level of the harmonic distortion of the harmonics relative to the main signal component.
Public field | Percent | THD as a percentage of the main signal component.

See Also

THD Structure


THD Fields

[image] [image]

Signal Processing Component Library for .NET Documentation
THD Fields
THD Structure See Also Send Feedback

The THD type exposes the following members.

Fields

 | Name | Description
Public field | dB | Total Harmonic Distortion (THD), returned in dB, represents the level of the harmonic distortion of the harmonics relative to the main signal component.
Public field | Percent | THD as a percentage of the main signal component.

See Also

THD Structure


THD.dB Field

[image]

Signal Processing Component Library for .NET Documentation
THD..::..dB Field
THD Structure See Also Send Feedback
Total Harmonic Distortion (THD), returned in dB, represents the level of the harmonic distortion of the harmonics relative to the main signal component.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double dB
Visual Basic
Public dB As Double

Field Value

Type: Double

See Also

THD Structure
THD Members


THD.Percent Field

[image]

Signal Processing Component Library for .NET Documentation
THD..::..Percent Field
THD Structure See Also Send Feedback
THD as a percentage of the main signal component.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double Percent
Visual Basic
Public Percent As Double

Field Value

Type: Double

See Also

THD Structure
THD Members


THD Methods

[image] [image]

Signal Processing Component Library for .NET Documentation
THD Methods
THD Structure See Also Send Feedback

The THD type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

THD Structure


Window Class

[image]

Signal Processing Component Library for .NET Documentation
Window Class
Members See Also Send Feedback
The Window class provides properties for configuring the time-domain windowing functions.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public class Window : Component, IDisposable
Visual Basic
Public Class Window
    Inherits Component
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
DataTranslation.SignalProcessing..::..Window

See Also

Window Members


Window Members

[image] [image]

Signal Processing Component Library for .NET Documentation
Window Members
Window Class Methods Properties Events See Also Send Feedback

The Window type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CosineTaperPercent | For the CosineTaper WindowType, gets and sets the percentage of the period in which the signal comes through unaltered before the signal ends are smoothed to zero.
Public property | ExpWindowFinalValue | For the Exponential WindowType, gets and sets the value (between 0 and 1) to which the signal is decayed at the end of the data.
Public property | ForceWindowEndPercent | For the Force WindowType, gets and sets the percentage of the period at which the rectangular window ends.
Public property | ForceWindowStartPercent | For the Force WindowType, gets and sets the percentage of the period at which the rectangular window starts.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | WindowType | Gets and sets the WindowType to apply to the time-domain data before performing the FFT operation.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

Window Class


Window Methods

[image] [image]

Signal Processing Component Library for .NET Documentation
Window Methods
Window Class See Also Send Feedback

The Window type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

Window Class


Window Properties

[image] [image]

Signal Processing Component Library for .NET Documentation
Window Properties
Window Class See Also Send Feedback

The Window type exposes the following members.

Properties

 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CosineTaperPercent | For the CosineTaper WindowType, gets and sets the percentage of the period in which the signal comes through unaltered before the signal ends are smoothed to zero.
Public property | ExpWindowFinalValue | For the Exponential WindowType, gets and sets the value (between 0 and 1) to which the signal is decayed at the end of the data.
Public property | ForceWindowEndPercent | For the Force WindowType, gets and sets the percentage of the period at which the rectangular window ends.
Public property | ForceWindowStartPercent | For the Force WindowType, gets and sets the percentage of the period at which the rectangular window starts.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | WindowType | Gets and sets the WindowType to apply to the time-domain data before performing the FFT operation.

See Also

Window Class


Window.CosineTaperPercent Property

[image]

Signal Processing Component Library for .NET Documentation
Window..::..CosineTaperPercent Property
Window Class See Also Send Feedback
For the CosineTaper WindowType, gets and sets the percentage of the period in which the signal comes through unaltered before the signal ends are smoothed to zero.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double CosineTaperPercent { get; set; }
Visual Basic
Public Property CosineTaperPercent As Double
    Get
    Set

Property Value

Type: Double

See Also

Window Class
Window Members


Window.ExpWindowFinalValue Property

[image]

Signal Processing Component Library for .NET Documentation
Window..::..ExpWindowFinalValue Property
Window Class See Also Send Feedback
For the Exponential WindowType, gets and sets the value (between 0 and 1) to which the signal is decayed at the end of the data.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double ExpWindowFinalValue { get; set; }
Visual Basic
Public Property ExpWindowFinalValue As Double
    Get
    Set

Property Value

Type: Double

Remarks

The Exponential window is equal to 1.0 at the beginning of the data and decays exponentially to a smaller value at the end of the data. Setting the ExpWindowFinalValue allows you to tailor the resultant FFT to the relevant time-domain data.

See Also

Window Class
Window Members


Window.ForceWindowEndPercent Property

[image]

Signal Processing Component Library for .NET Documentation
Window..::..ForceWindowEndPercent Property
Window Class See Also Send Feedback
For the Force WindowType, gets and sets the percentage of the period at which the rectangular window ends.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double ForceWindowEndPercent { get; set; }
Visual Basic
Public Property ForceWindowEndPercent As Double
    Get
    Set

Property Value

Type: Double

Remarks

The Force window allows you to specify the percentage of the signal period to which the rectangular window is applied.

See Also

Window Class
Window Members


Window.ForceWindowStartPercent Property

[image]

Signal Processing Component Library for .NET Documentation
Window..::..ForceWindowStartPercent Property
Window Class See Also Send Feedback
For the Force WindowType, gets and sets the percentage of the period at which the rectangular window starts.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public double ForceWindowStartPercent { get; set; }
Visual Basic
Public Property ForceWindowStartPercent As Double
    Get
    Set

Property Value

Type: Double

Remarks

The Force window allows you to specify the percentage of the signal period to which the rectangular window is applied.

See Also

Window Class
Window Members


Window.WindowType Property

[image]

Signal Processing Component Library for .NET Documentation
Window..::..WindowType Property
Window Class See Also Send Feedback
Gets and sets the WindowType to apply to the time-domain data before performing the FFT operation.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public WindowType WindowType { get; set; }
Visual Basic
Public Property WindowType As WindowType
    Get
    Set

Property Value

Type: WindowType

See Also

Window Class
Window Members


Window Events

[image] [image]

Signal Processing Component Library for .NET Documentation
Window Events
Window Class See Also Send Feedback

The Window type exposes the following members.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

Window Class


WindowType Enumeration

[image]

Signal Processing Component Library for .NET Documentation
WindowType Enumeration
See Also Send Feedback
The windowing type to apply to time-domain source data. This enumeration is used by the WindowType property.

Namespace: DataTranslation.SignalProcessing
Assembly: DataTranslation.SignalProcessing (in DataTranslation.SignalProcessing.dll) Version: 1.0.0.3 (1.0.0.3)

Syntax

C#
public enum WindowType
Visual Basic
Public Enumeration WindowType

Members

Member name | Value | Description
Rectangular | 0 | No window. Recommended for use when your signal content contains random noise (white noise) or closely spaced sine waves.
Hamming | 1 | Bell-shaped cosine window optimized to minimize the maximum (nearest) side lobe. Recommended for use when your signal content consists of closely spaced sine waves.
Hanning | 2 | Bell-shaped cosine window typically used to analyze continuous signals. Recommended for use when your signal content contains sine waves, a combination of sine waves, vibration data consisting of narrowband random signals, or unknown content.
Bartlett | 3 | Triangular window.
Blackman | 4 | Similar to the Hanning and Hamming windows, this window has slightly wider central lobes and less sideband leakage.
BlackmanHarris | 5 | Similar to Hanning window, this window has a slightly wider main lobe but much better dynamic range. It is optimized to provide the minimum side lobe level.
FlatTop | 6 | Optimized for measuring peak amplitudes of discrete spectral components that are separated by several spectral lines. Recommended for use when your signal content consists of sine waves and amplitude accuracy is important.
CosineTaper | 7 | This window allows you to specify the percentage of the period to allow the signal to come through unaltered before smoothing the signal ends to zero. This windowing type is typically used with reference channels when performing two-channel FFT operations.
Force | 8 | This window allows you to specify the percentage of the signal period to which the rectangular window is applied. Data outside the selected percentage is forced to zero. You can specify the percentage of the period at which the rectangular window starts and the percentage of the signal period at which the rectangular window stops. By applying this window to the output of a transducer, you can avoid collecting extraneous signals, such as forces from the retraction of a hammer, that are not important to the measurement. This windowing type is typically used with reference channels when performing two-channel FFT operations.
Exponential | 9 | This window is equal to 1.0 at the beginning of the data and decays exponentially to a smaller value at the end of the data. You can specify a value between 0 and 1 as the exponential factor. This value indicates how much to decay the signal, allowing you to tailor the resultant FFT to the relevant data. This windowing type is typically used with response channels when performing two-channel FFT operations.

See Also

DataTranslation.SignalProcessing Namespace

Send comments on this topic to info@datx.com

Copyright © 2013 by Data Translation, Inc.